Sign in to follow this  
Followers 0
do_Obie

Unable To Parse Line?

10 posts in this topic

So I am new to autoit and started by using a script a friend gave me. I wrote this:

Code:

Global $Paused

HotKeySet("{END}", "TogglePause")

HotKeySet("{HOME}", "Terminate")

While 1

Sleep(100)

WEnd

Func TogglePause()

$Paused = NOT $Paused

While $Paused

sleep(10)

MouseClick("Left")

WEnd

EndFunc

Func Terminate()

Exit 0

EndFunc

In notepad and saved as a .au3 file. But when I try to open it it says "Error unable to parse line"

If someone coule please help me out it would be greatly appreciated.

Share this post


Link to post
Share on other sites



The Script works fine for me.

You should download Scite and try to run it.

Share this post


Link to post
Share on other sites

Scite?

Share this post


Link to post
Share on other sites
Scite4AutoIt3 clicky

AutoIt Console written in C#. Write au3 code right at the console :D_FileWriteToLineWrite to a specific line in a file.My UDF Libraries: MySQL UDF Library version 1.6 MySQL Database UDF's for AutoItI have stopped updating the MySQL thread above, all future updates will be on my SVN. The svn location is:kan2.sytes.net/publicsvn/mysqlnote: This will still be available, but due to my new job, and school hours, am no longer developing this udf.My business: www.hirethebrain.com Hire The Brain HireTheBrain.com Computer Consulting, Design, Assembly and RepairOh no! I've commited Scriptocide!

Share this post


Link to post
Share on other sites

Hmm ok I dled and installed that and I get the same error. It says it is unable to parse line 1 (The directory path of the file). I tried moving it to different places and it just gives me the same error with the new path.

Share this post


Link to post
Share on other sites

inside scite -> Options -> a3u Properties->

# *** Specify here your AutoIt program directory ***

autoit3dir=X:\XYZ\Autoit3\ <--------

Share this post


Link to post
Share on other sites

umust be doing something wrong, or have something in there because it works just fine

Global $Paused
HotKeySet("{END}", "TogglePause")
HotKeySet("{HOME}", "Terminate")

While 1
Sleep(100)
WEnd

Func TogglePause()
$Paused = NOT $Paused
While $Paused
sleep(10)
MouseClick("Left")
WEnd
EndFunc

Func Terminate()
Exit 0
EndFunc

Share this post


Link to post
Share on other sites

I check the directory and it is right. I just dont see how Im doing anything wrong. Its a brand new installation and I copy / pasted the code into notepad and saved it correctly.

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

ummm stop using notepad, use scite its ALLLLOOOOOOOOT better, it highlights the syntax and everything follow the link in the posts above :think: , the only problem i can think of is sumhow ur saving it as a name.au3.txt and that could be screwing you up

Edited by thatsgreat2345

Share this post


Link to post
Share on other sites

Ok yea it was saving as .au3.txt and that was screwing me up. Thanks alot I got it working :think:.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0