Sign in to follow this  
Followers 0
helldragon

Pixelgetcolor, Mine Wont Work...

21 posts in this topic

ok guys i need some help... yet again, i went to do my party section of my script, problem is... it never even starts up the party section of the script...

; ----------------------------------------------------------------------------
;
; AutoIt Version: 3.1.0
; Author:        HellsDragon
;
; Script Function:
;   SRO Restart script.
;
; ----------------------------------------------------------------------------

; Script Start - Begin the mofo

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Declarations                                                                      ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

$Scrack=("C:\Documents and Settings\David\Desktop\Bot110\SCrack.exe")
$SRO=("C:\Program Files\Silkroad\Silkroad.exe")
$SROEXE=("sro_client.exe")
$SROLaunch=("Silkroad Online Launcher")
$acct=("account")
$pass=("password")
$connected=0
$disconnected=0

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Main Code                                                                        ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

if processexists($SROEXE) Then
    $connected=1
    $disconnected=0
Else
    $connected=0
    $disconnected=1
endif


While $Connected=0
    programs()
    login()
    if $connected=2 Then
        botstart()
    EndIf
WEnd

while $Connected=2
    sleep(5000)
    send("{Enter}")
WEnd
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Functions                                                                        ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

func programs()
if $disconnected=1 then
    run ($Scrack);launch crack
    sleep(12000)
    run($SRO);launch sro launcher
    sleep(6000)
    mouseclick("left", 863, 631, 1, 3);click launch
    $connected=1
EndIf


endfunc;ending programs()
if $disconnected=1 Then
    run ($Scrack);launch crack
    sleep(10000)
    Run($SRO);launch sro launcher
    sleep(10000)
    mouseclick("left", 863, 631, 1, 3);click launch
EndIf

func login()
    if $connected=1 Then
        sleep(10000)
        winactivate($SROexe)
        sleep(1000)
        send("{ENTER}")
        sleep(1000)
        mouseclick("left",675 ,550 ,1 ,0)
        sleep(1000)
        send($acct)
        
        sleep(1000)
        send("{TAB}")
        sleep(1000)
        send($pass)
        send("{ENTER}")
        sleep(9000)
        MouseClick ("Left", 397, 500, 3, 5); 1st char
        Sleep (5000)
        MouseClick ("Left", 992, 939, 2, 0); start
        $connected=2
    EndIf
endfunc;end of login
    
func botstart()
    sleep(1000)
mouseclick("right", 500, 500, 1, 0)
MouseWheel("down", 8);display
sleep(100)
MouseClick ("Left", 11, 960, 4, 3); chat
if $connected=2 Then
    sleep(10000)
    send("{INSERT}")
    While 1
        Sleep(5000)
        send("{ENTER}")
    Wend
EndIf

If  PixelGetColor(39, 93) <> 16726845   Then
Do
    Send("e")
    Sleep(1000)
    MouseClick ("Left", 390, 590, 1, 0)
    Sleep(2000)
    MouseClick ("Left", 465, 525, 1, 0)
    Sleep(5000)
    Send("e")
Until   PixelGetColor(39, 93) = 16726845
endif
endfunc;ending botstart

Share this post


Link to post
Share on other sites



bump...

Share this post


Link to post
Share on other sites

ok guys i need some help... yet again, i went to do my party section of my script, problem is... it never even starts up the party section of the script...

CODE

; ----------------------------------------------------------------------------

;

; AutoIt Version: 3.1.0

; Author: HellsDragon

;

; Script Function:

; SRO Restart script.

;

; ----------------------------------------------------------------------------

; Script Start - Begin the mofo

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

;Declarations ;

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

$Scrack=("C:\Documents and Settings\David\Desktop\Bot110\SCrack.exe")

$SRO=("C:\Program Files\Silkroad\Silkroad.exe")

$SROEXE=("sro_client.exe")

$SROLaunch=("Silkroad Online Launcher")

$acct=("account")

$pass=("password")

$connected=0

$disconnected=0

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

;Main Code ;

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

if processexists($SROEXE) Then

$connected=1

$disconnected=0

Else

$connected=0

$disconnected=1

endif

While $Connected=0

programs()

login()

if $connected=2 Then

botstart()

EndIf

WEnd

while $Connected=2

sleep(5000)

send("{Enter}")

WEnd

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

;Functions ;

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

func programs()

if $disconnected=1 then

run ($Scrack);launch crack

sleep(12000)

run($SRO);launch sro launcher

sleep(6000)

mouseclick("left", 863, 631, 1, 3);click launch

$connected=1

EndIf

endfunc;ending programs()

if $disconnected=1 Then

run ($Scrack);launch crack

sleep(10000)

Run($SRO);launch sro launcher

sleep(10000)

mouseclick("left", 863, 631, 1, 3);click launch

EndIf

func login()

if $connected=1 Then

sleep(10000)

winactivate($SROexe)

sleep(1000)

send("{ENTER}")

sleep(1000)

mouseclick("left",675 ,550 ,1 ,0)

sleep(1000)

send($acct)

sleep(1000)

send("{TAB}")

sleep(1000)

send($pass)

send("{ENTER}")

sleep(9000)

MouseClick ("Left", 397, 500, 3, 5); 1st char

Sleep (5000)

MouseClick ("Left", 992, 939, 2, 0); start

$connected=2

EndIf

endfunc;end of login

func botstart()

sleep(1000)

mouseclick("right", 500, 500, 1, 0)

MouseWheel("down", 8);display

sleep(100)

MouseClick ("Left", 11, 960, 4, 3); chat

if $connected=2 Then

sleep(10000)

send("{INSERT}")

While 1

Sleep(5000)

send("{ENTER}")

Wend

EndIf

If PixelGetColor(39, 93) <> 16726845 Then

Do

Send("e")

Sleep(1000)

MouseClick ("Left", 390, 590, 1, 0)

Sleep(2000)

MouseClick ("Left", 465, 525, 1, 0)

Sleep(5000)

Send("e")

Until PixelGetColor(39, 93) = 16726845

endif

endfunc;ending botstart

Exactly how many how many how many threads are you going to run with this same script? :think:


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

hehe firstly, how many times are u gonna say how many? :think: lols, and each time its something different...and each time i add more and more to the script

Share this post


Link to post
Share on other sites

ive paticulary never use <> but im assuming its greathan or less than if im not mistaken?

well if its not workng i'd say add and or statement like

If  PixelGetColor(39, 93) < 16726845 or PixelGetColor(39,93) > 16726845   Then

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

hehe firstly, how many times are u gonna say how many? :think: lols, and each time its something different...and each time i add more and more to the script

Yeah, I saw you had a different step in each thread... just late nite humor. On your script - I don't get the logic of your IF-Else-EndIf followed by the two While-Wend loops. If the processexists($SROEXE) returns 1 then neither While loop will run and the script exits. Is that really what you wanted?

Oops, I just notice you have more Main code in the section labeled "Functions"... very confusing...

Edited by PsaltyDS

Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Yeah, I saw you had a different step in each thread... just late nite humor. On your script - I don't get the logic of your IF-Else-EndIf followed by the two While-Wend loops. If the processexists($SROEXE) returns 1 then neither While loop will run and the script exits. Is that really what you wanted?

i think thats what he wants cuz then the game would already be running and there would be no point in rerunning it

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

no salty is right, the game crashes often, its part of my bad coding, im not too great at it :think: unfortunately, i just realised that it didnt work too. any assistance? :(

p.s. when i change hte code to what great suggested, it still doesnt work :)

Edited by helldragon

Share this post


Link to post
Share on other sites

no salty is right, the game crashes often, its part of my bad coding, im not too great at it :) unfortunately, i just realised that it didnt work too. any assistance? ;)

p.s. when i change hte code to what great suggested, it still doesnt work :D

Just for the sake of my sanity... move your main body code together at the top so only Functions are list in the "Functions" section :think:

I don't know your game so there is no way to know exactly what will work, but the DO/UNTIL loop is not what you wanted. I can tell it's not because you do that IF test before running it. This is equivelent to what I think you meant:

While PixelGetColor(39, 93) <> 16726845
    Send("e")
    Sleep(1000)
    MouseClick("Left", 390, 590, 1, 0)
    Sleep(2000)
    MouseClick("Left", 465, 525, 1, 0)
    Sleep(5000)
    Send("e")
WEnd

Hope that helps... :(


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

ok cool, ill give that a shot, and im having one other problem also... instead of just doing

send("{ENTER}")
and having it do it to everything... how can i make it to send just to the client... i tried this... but its not working...

Controlsend("SRO_Client","","","{ENTER}")

im not sure if im doing it correctly though...

Share this post


Link to post
Share on other sites

ok cool, ill give that a shot, and im having one other problem also... instead of just doing

send("{ENTER}")
and having it do it to everything... how can i make it to send just to the client... i tried this... but its not working...

Controlsend("SRO_Client","","","{ENTER}")

im not sure if im doing it correctly though...

Did you know that the help file that comes with AutoIT is also the complete command reference (with examples)?! :think:

Check the help file for ControlSend(). The first parameter is supposed to be the window title, and I got the impression that "SRO_Client" was the process name vice the window title. Also, the third parameter is the required control ID, which you defaulted to "". You also need a flag of 0 after the "{Enter}" to indicate the string is not raw: {, E, N, T, E, R, }. Keep the help file open the whole time you work with AutoIT.


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

yes i knew that, but i cannot get the controlID, the info thing wont show me the numbers for it, and another question... do you happen to know the reason why after the program crashes, it does not restart everything? like go back to the top and begin it all over again??

EDIT-ok i got the controlid things to work, controlID i left as default, because there isnt one... it was the flag thing that was messing it up, but i still cannot get it to loop itself... any help??

Edited by helldragon

Share this post


Link to post
Share on other sites

yes i knew that, but i cannot get the controlID, the info thing wont show me the numbers for it, and another question... do you happen to know the reason why after the program crashes, it does not restart everything? like go back to the top and begin it all over again??

EDIT-ok i got the controlid things to work, controlID i left as default, because there isnt one... it was the flag thing that was messing it up, but i still cannot get it to loop itself... any help??

Can you repost the code as it stands now? I want to look where you might poke something like:

While 1
     While WinExisits("Window Title")
         ; Do stuff while window is running...
     Wend

     Do
         ; Stuff to bring it back when not running...
     Until WinExists("Window Title")
Wend

Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

ive paticulary never use <> but im assuming its greathan or less than if im not mistaken?

well if its not workng i'd say add and or statement like

If  PixelGetColor(39, 93) < 16726845 or PixelGetColor(39,93) > 16726845   Then
<> means, Does not equal.

AutoIt Scripts:Aimbot: Proof of Concept - PixelSearching Aimbot with several search/autoshoot/lock-on techniques.Sliding Toolbar - Add a nice Sliding Toolbar to your next script. Click the link to see an animation of it in action!FontInfo UDF - Get list of system fonts, or search to see if a particular font is installed.Get Extended Property UDF - Retrieve a files extended properties (e.g., video/image dimensions, file version, bitrate of song/video, etc)

Share this post


Link to post
Share on other sites

<> means, Does not equal.

I got confused a couple times trying to use "If Not $x = $y Then" (bad habit from DOS shell scripting), before I got it through my skull that it has to be done with "If $x <> $y Then". A demo of what was tripping me up:

; Test NOT operation
For $a = 0 To 2
    If Not $a = 1 Then ; Does not work as expected
        $TF_1 = "TRUE"
    Else
        $TF_1 = "FALSE"
    EndIf
    
    If $a <> 1 Then ; Works as expected
        $TF_2 = "TRUE"
    Else
        $TF_2 = "FALSE"
    EndIf
    
    MsgBox(64, "Test NOT vs <>", "$a = " & $a & @CRLF & _
            "'If Not $a = 1' was: " & $TF_1 & @CRLF & _
            "'If $a <> 1' was: " & $TF_2)
Next

:think:


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

ok here is the script as it stands right now

; ----------------------------------------------------------------------------
;
; AutoIt Version: 3.1.0
; Author:        HellsDragon
;
; Script Function:
;   SRO Restart script.
;
; ----------------------------------------------------------------------------

; Script Start - Begin the mofo

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Declarations                                                                      ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

$Scrack=("C:\Documents and Settings\David\Desktop\Bot110\SCrack.exe")
$SRO=("C:\Program Files\Silkroad\Silkroad.exe")
$SROEXE=("sro_client.exe")
$SROLaunch=("Silkroad Online Launcher")
$acct=("account")
$pass=("password")
$connected=0
$disconnected=0

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Main Code                                                                        ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

if processexists($SROEXE) Then
    $connected=1
    $disconnected=0
Else
    $connected=0
    $disconnected=1
endif


While $Connected=0
    programs()
    login()
    if $connected=2 Then
        botstart()
    EndIf
WEnd

while $Connected=2
    sleep(5000)
    send("{Enter}")
WEnd
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Functions                                                                        ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

func programs()
if $disconnected=1 then
    run ($Scrack);launch crack
    sleep(12000)
    run($SRO);launch sro launcher
    sleep(6000)
    mouseclick("left", 863, 631, 1, 3);click launch
    $connected=1
EndIf


endfunc;ending programs()
if $disconnected=1 Then
    run ($Scrack);launch crack
    sleep(10000)
    Run($SRO);launch sro launcher
    sleep(10000)
    mouseclick("left", 863, 631, 1, 3);click launch
EndIf

func login()
    if $connected=1 Then
        sleep(10000)
        winactivate($SROexe)
        sleep(1000)
        send("{ENTER}")
        sleep(1000)
        mouseclick("left",675 ,550 ,1 ,0)
        sleep(1000)
        send($acct)
        
        sleep(1000)
        send("{TAB}")
        sleep(1000)
        send($pass)
        send("{ENTER}")
        sleep(9000)
        MouseClick ("Left", 397, 500, 3, 5); Press first character
        Sleep (5000)
        MouseClick ("Left", 992, 939, 2, 0); press start
        $connected=2
    EndIf
endfunc;end of login
    
func botstart()
    sleep(1000)
mouseclick("right", 500, 500, 1, 0)
MouseWheel("down", 8);Just to expand visual distance ingame
sleep(100)
MouseClick ("Left", 11, 960, 4, 3); Expands Chat window
if $connected=2 Then
    sleep(10000)
    send("{INSERT}")
    While 1
        Sleep(60000)
        Controlsend("SRO_Client","","","{ENTER}",0)
    Wend
EndIf
    Send("e")
    Sleep(1000)
    MouseClick("Left", 390, 590, 1, 0)
    Sleep(2000)
    MouseClick("Left", 465, 525, 1, 0)
    Sleep(5000)
    Send("e")
    sleep (6000)
endfunc;ending botstart

Share this post


Link to post
Share on other sites

ok here is the script as it stands right now

CODE

; ----------------------------------------------------------------------------

;

; AutoIt Version: 3.1.0

; Author: HellsDragon

;

; Script Function:

; SRO Restart script.

;

; ----------------------------------------------------------------------------

; Script Start - Begin the mofo

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

;Declarations ;

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

$Scrack=("C:\Documents and Settings\David\Desktop\Bot110\SCrack.exe")

$SRO=("C:\Program Files\Silkroad\Silkroad.exe")

$SROEXE=("sro_client.exe")

$SROLaunch=("Silkroad Online Launcher")

$acct=("account")

$pass=("password")

$connected=0

$disconnected=0

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

;Main Code ;

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

if processexists($SROEXE) Then

$connected=1

$disconnected=0

Else

$connected=0

$disconnected=1

endif

While $Connected=0

programs()

login()

if $connected=2 Then

botstart()

EndIf

WEnd

while $Connected=2

sleep(5000)

send("{Enter}")

WEnd

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

;Functions ;

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

func programs()

if $disconnected=1 then

run ($Scrack);launch crack

sleep(12000)

run($SRO);launch sro launcher

sleep(6000)

mouseclick("left", 863, 631, 1, 3);click launch

$connected=1

EndIf

endfunc;ending programs()

if $disconnected=1 Then

run ($Scrack);launch crack

sleep(10000)

Run($SRO);launch sro launcher

sleep(10000)

mouseclick("left", 863, 631, 1, 3);click launch

EndIf

func login()

if $connected=1 Then

sleep(10000)

winactivate($SROexe)

sleep(1000)

send("{ENTER}")

sleep(1000)

mouseclick("left",675 ,550 ,1 ,0)

sleep(1000)

send($acct)

sleep(1000)

send("{TAB}")

sleep(1000)

send($pass)

send("{ENTER}")

sleep(9000)

MouseClick ("Left", 397, 500, 3, 5); Press first character

Sleep (5000)

MouseClick ("Left", 992, 939, 2, 0); press start

$connected=2

EndIf

endfunc;end of login

func botstart()

sleep(1000)

mouseclick("right", 500, 500, 1, 0)

MouseWheel("down", 8);Just to expand visual distance ingame

sleep(100)

MouseClick ("Left", 11, 960, 4, 3); Expands Chat window

if $connected=2 Then

sleep(10000)

send("{INSERT}")

While 1

Sleep(60000)

Controlsend("SRO_Client","","","{ENTER}",0)

Wend

EndIf

Send("e")

Sleep(1000)

MouseClick("Left", 390, 590, 1, 0)

Sleep(2000)

MouseClick("Left", 465, 525, 1, 0)

Sleep(5000)

Send("e")

sleep (6000)

endfunc;ending botstart

OK, first, you still had some main sequence code in the "Functions" section, so I moved it up. Then I trimmed out all the places where extraneous flags were used ($connected, $disconnected). Then I put the main sequence in a While loop (to run forever). Inside the main loop, I put two While loops. The first one will loop as long as that process exists. If the process goes away, that While loop will exit, and the main loop goes to the second While loop, which keeps trying until the process does exist, then the main loop goes back to the first loop. Clear as mud? :think:

Your botstart() function looked like a trap to me because I didn't see anything to break you out of the While loop that was in it.

I may have misinterpreted what you were shooting for, but cleaning it up should help anyway:

; ----------------------------------------------------------------------------
;
; AutoIt Version: 3.1.0
; Author:        HellsDragon
;
; Script Function:
;   SRO Restart script.
;
; ----------------------------------------------------------------------------

; Script Start - Begin the mofo

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Declarations                                                                     ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

$Scrack= ("C:\Documents and Settings\David\Desktop\Bot110\SCrack.exe")
$SRO= ("C:\Program Files\Silkroad\Silkroad.exe")
$SROEXE= ("sro_client.exe")
$acct= ("account")
$pass= ("password")

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Main Code                                                                       ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

While 1 
    While ProcessExists($SROEXE) ; Loops while program is running
        ControlSend("SRO_Client", "", "", "{ENTER}", 0)
        Sleep(60000)
    WEnd
    
    While Not ProcessExists($SROEXE) ; Loops while program is missing
        programs()
        login()
        botstart()
    WEnd
WEnd

;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;
;Functions                                                                       ;
;-==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==-;

Func programs()
    Run($Scrack);launch crack
    Sleep(12000)
    Run($SRO);launch sro launcher
    Sleep(6000)
    MouseClick("left", 863, 631, 1, 3);click launch
    Sleep(6000)
EndFunc  ;==>programs

Func login()
    Sleep(10000)
    WinActivate($SROEXE)
    Sleep(1000)
    Send("{ENTER}")
    Sleep(1000)
    MouseClick("left", 675, 550, 1, 0)
    Sleep(1000)
    Send($acct)
    
    Sleep(1000)
    Send("{TAB}")
    Sleep(1000)
    Send($pass)
    Send("{ENTER}")
    Sleep(9000)
    MouseClick("Left", 397, 500, 3, 5); Press first character
    Sleep(5000)
    MouseClick("Left", 992, 939, 2, 0); press start
    Sleep(6000)
EndFunc  ;==>login

Func botstart()
    Sleep(1000)
    MouseClick("right", 500, 500, 1, 0)
    MouseWheel("down", 8);Just to expand visual distance ingame
    Sleep(100)
    MouseClick("Left", 11, 960, 4, 3); Expands Chat window
    Sleep(10000)
    Send("{INSERT}")
    Sleep(100)
    Send("e")
    Sleep(1000)
    MouseClick("Left", 390, 590, 1, 0)
    Sleep(2000)
    MouseClick("Left", 465, 525, 1, 0)
    Sleep(5000)
    Send("e")
    Sleep(6000)
EndFunc  ;==>botstart

Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

ok it works up to a certain point... i fell asleep at the keyboard... and when i woke up i had about 20 silkroad.exe's running and 20 scracks.exe's running.. lol computer didnt handle that all too well rofl, any idea why?

Share this post


Link to post
Share on other sites

#19 ·  Posted (edited)

...about 20 silkroad.exe's running and 20 scracks.exe's running.. lol computer didnt handle that all too well rofl, any idea why?

Not enough RAM?

:think:;):D:):(

Ok, all seriousness aside... The second While loop inside the main While loop will keep repeating those three function untill it sees the process exists. Maybe the Sleep() times aren't long enough for the process to be there and prevent another cycle of the loop, so it kicks another copy? You'll have to follow through it carefully and see if the three fuctions are getting the job done.

Edited by PsaltyDS

Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

lolol no no, not that lols the reason why 20 of each were running :think:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0