Sign in to follow this  
Followers 0
Daniel W.

Problem With Array.au3

7 posts in this topic

Hi,

every script that needs array.au3 doesnt work because then i get an error like this:

Posted Image

On the screen you see the line "171" which includes the Error ....

I have the latest beta and i have downloaded it again and took the array.au3 from it to Include dir

Nothign helped and i dont know where the error is.

regards Daniel w.


--------------------------------------------------------------------------------------------------------------------------------Scripts : _Encrypt UDF_UniquePCCode UDF MS like calculatorInstall programm *UPDATED* --------------------------------------------------------------------------------------------------------------------------------[quote name='Helge' post='213117' date='Jul 26 2006, 10:22 AM']Have you ever tried surfing the internet with a milk-carton ?This is similar to what you're trying to do.[/quote]

Share this post


Link to post
Share on other sites



you sure your using beta

Share this post


Link to post
Share on other sites

yes i am

I installed first autoit then beta then scite

and if i make Betarun or beta syntax check i get these errors too


--------------------------------------------------------------------------------------------------------------------------------Scripts : _Encrypt UDF_UniquePCCode UDF MS like calculatorInstall programm *UPDATED* --------------------------------------------------------------------------------------------------------------------------------[quote name='Helge' post='213117' date='Jul 26 2006, 10:22 AM']Have you ever tried surfing the internet with a milk-carton ?This is similar to what you're trying to do.[/quote]

Share this post


Link to post
Share on other sites

Use Alt+F5 when using SciTe to use the Beta options, and you will not get the issue any longer.

Or go through your standard include folder in the Release version and remove the word Const from all the function parameters.


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Alt+F5 in Scite returns this:

>"C:\Programme\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /beta /ErrorStdOut /in "C:\Dokumente und Einstellungen\Schnubby\Desktop\Neu AutoIt v3 Script.au3" /autoit3dir "C:\Program Files\AutoIt3\beta" /UserParams  
>Running AU3Check   params:  from:C:\Programme\AutoIt3\SciTE\au3check\
+>AU3Check ended.rc:0
>Running:(3.1.1.0):C:\Programme\AutoIt3\autoit3.exe "C:\Dokumente und Einstellungen\Schnubby\Desktop\Neu AutoIt v3 Script.au3"  
C:\Programme\AutoIt3\Include\Array.au3 (171) : ==> Badly formatted "Func" statement.: 
Func _ArrayDisplay(Const ByRef $avArray, $sTitle) 
Func _ArrayDisplay(^ ERROR
->AutoIT3.exe ended.rc:1
>Exit code: 1   Time: 1.982

€: Beautiful i hate my PC .... I gonna reinstall all ...

€²: Works not Thanks to all

Edited by Daniel W.

--------------------------------------------------------------------------------------------------------------------------------Scripts : _Encrypt UDF_UniquePCCode UDF MS like calculatorInstall programm *UPDATED* --------------------------------------------------------------------------------------------------------------------------------[quote name='Helge' post='213117' date='Jul 26 2006, 10:22 AM']Have you ever tried surfing the internet with a milk-carton ?This is similar to what you're trying to do.[/quote]

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Alt+F5 in Scite returns this:

: Beautiful i hate my PC .... I gonna reinstall all ...

Shows there your running 3.1.1 release version not Beta, did you use the SciTe >> Tools >> Beta Run ? Edited by SmOke_N

[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

I did installed it and thought it would be used ...

now i reinstalled all of autoit in the same order like i did before and it works :)


--------------------------------------------------------------------------------------------------------------------------------Scripts : _Encrypt UDF_UniquePCCode UDF MS like calculatorInstall programm *UPDATED* --------------------------------------------------------------------------------------------------------------------------------[quote name='Helge' post='213117' date='Jul 26 2006, 10:22 AM']Have you ever tried surfing the internet with a milk-carton ?This is similar to what you're trying to do.[/quote]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0