Sign in to follow this  
Followers 0
raca

Control Problem

19 posts in this topic

#1 ·  Posted (edited)

hi

i have being playing with controls with ControlCommand() and i have disable the adress bar on internet explorer :s it doesn't show up

reboot didn't work. with registry mechanic to detect something wrong on the registry didn't work either.

does someone know how to enable it again?

Edited by raca

Share this post


Link to post
Share on other sites



I would like to see your code, and is your program still running?

Have you looked in you IE settings to be sure it is still checked to be showing? Also unlock the toolbar, and look around it may just barely be sitting off to the side.

I hope this helps,

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

Did you use HideDropDown, and if so, did you try ShowDropDown?


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

i deleted the code.. i was just trying things didn't realize what I did.

i have check the options... even in the normal folder explorer the adress doesn't show up even if it's enabled on the options.

the code was something like this:

ControlDisable ( "Program Manager","","Internet Explorer_Server2")

or

ControlHide ( "Program Manager","","Internet Explorer_Server2")

Share this post


Link to post
Share on other sites

hrm... I cant seem to find a solution as I cannot duplicate the problem :).

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

didn't work :s

i tried even to del the hole HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer tree didn't work.

i also disable/hide a control something called Deskmover that is a bar that shows up when you have a active desktop item... the bar that have the, X close button

i don't know what to try...

where are the controls defenitions stored?

Share this post


Link to post
Share on other sites

Can you provide some screen shots for me... of IE, and then of the menu showing where Address Bar is enabled?

Thanks,

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

here they are

im using Windows XP SP2 in Portuguese.

some translations:

"Ver" = View

"Barra de ferramentas" = Tool bar

"Barra 'Endereço'" = Address bar

Share this post


Link to post
Share on other sites

#10 ·  Posted

here they are

im using Windows XP SP2 in Portuguese.

some translations:

"Ver" = View

"Barra de ferramentas" = Tool bar

"Barra 'Endereço'" = Address bar

For the sheer fun of it please try the following...

Close all IE instances.

Open one IE instance.

Goto View>Toolbar and UnCheck Address Bar.

Close IE.

Restart Windows.

Open one IE instance.

Goto View>Toolbar and Check Address Bar.

Let me know how that goes... may even want to close and restart after re-enabling just for the sheer fun of it.

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

#11 ·  Posted

For the sheer fun of it please try the following...

Close all IE instances.

Open one IE instance.

Goto View>Toolbar and UnCheck Address Bar.

Close IE.

Restart Windows.

Open one IE instance.

Goto View>Toolbar and Check Address Bar.

didn't work...

could you tell me thar correct name of the control of the bar in the active desktop?

i wanna try what i should have already done.. do controlshow and controlenable

Share this post


Link to post
Share on other sites

#12 ·  Posted

didn't work...

could you tell me thar correct name of the control of the bar in the active desktop?

i wanna try what i should have already done.. do controlshow and controlenable

i was able to duplicate this, and correct it on my system.

i hid the address bar with:

ControlHide("Google - Micros","",41477); "Edit2" may work for the control id also

that hid just the edit/combobox (it's actually 2 controls with same control id, and 2 names). then to re-enable i just did

ControlShow("Google - Micros","",41477)

in order to see the change, i had to go to view/toolbars and uncheck then re-check address bar. worst case scenario, install autoit on another computer with the same operating system, and use window info tool to get the control id you have to use to interact with the address bar.


1100111 00001011101111 00011101101111 00010111100100 00001111110100 00110111110010 00101101111001 0011100i didn't make up this form of encryption, but i like it.credit to the lvl 6 challenge on arcanum.co.nz

Share this post


Link to post
Share on other sites

#13 ·  Posted

i was able to duplicate this, and correct it on my system.

i hid the address bar with:

ControlHide("Google - Micros","",41477); "Edit2" may work for the control id also

that hid just the edit/combobox (it's actually 2 controls with same control id, and 2 names). then to re-enable i just did

ControlShow("Google - Micros","",41477)

in order to see the change, i had to go to view/toolbars and uncheck then re-check address bar. worst case scenario, install autoit on another computer with the same operating system, and use window info tool to get the control id you have to use to interact with the address bar.

Well done Cameronsdad... havent seen you around in a while :) Glad to see you helping as usual!

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

#14 ·  Posted

Well done Cameronsdad... havent seen you around in a while :) Glad to see you helping as usual!

JS

thanks, glad to be back. i actually got moved at work, so i've been re-establishing myself here a little bit. just a different side of the same office, but now i have a diff sup etc. should be back to normal now though.

1100111 00001011101111 00011101101111 00010111100100 00001111110100 00110111110010 00101101111001 0011100i didn't make up this form of encryption, but i like it.credit to the lvl 6 challenge on arcanum.co.nz

Share this post


Link to post
Share on other sites

#15 ·  Posted

i was able to duplicate this, and correct it on my system.

i hid the address bar with:

ControlHide("Google - Micros","",41477); "Edit2" may work for the control id also

that hid just the edit/combobox (it's actually 2 controls with same control id, and 2 names). then to re-enable i just did

ControlShow("Google - Micros","",41477)

in order to see the change, i had to go to view/toolbars and uncheck then re-check address bar. worst case scenario, install autoit on another computer with the same operating system, and use window info tool to get the control id you have to use to interact with the address bar.

didn't work...

i try create another acount to see if with other user it was fine... no luck

doesn't anyone a tool to lock for wrong congurations of the controls.. or something like that?

Share this post


Link to post
Share on other sites

#16 ·  Posted

didn't work...

i try create another acount to see if with other user it was fine... no luck

doesn't anyone a tool to lock for wrong congurations of the controls.. or something like that?

do you have access to another machine using the same operating system? if so, then just install autoit on that machine and get the control id for the address bar on that machine. it should be the same for yours. then just use the lines i posted, with the corrected control id, and hide/show the address bar.

1100111 00001011101111 00011101101111 00010111100100 00001111110100 00110111110010 00101101111001 0011100i didn't make up this form of encryption, but i like it.credit to the lvl 6 challenge on arcanum.co.nz

Share this post


Link to post
Share on other sites

do you have access to another machine using the same operating system? if so, then just install autoit on that machine and get the control id for the address bar on that machine. it should be the same for yours. then just use the lines i posted, with the corrected control id, and hide/show the address bar.

done it... didn't work

i'm going to try other ways... last resort... format

wish me luck

Share this post


Link to post
Share on other sites

#18 ·  Posted (edited)

done it... didn't work

i'm going to try other ways... last resort... format

wish me luck

format?! screw that. it's not THAT serious yet is it? try doing a repair first, or install an older version of IE over your current one, then update it... sorry, format i think should be the last last last resort.

***edit***

oh yeah, you CAN navigate to websites from the run prompt, you know that right? press windows+R to get run box and type in an address http://google.com and it will go there...

Edited by cameronsdad

1100111 00001011101111 00011101101111 00010111100100 00001111110100 00110111110010 00101101111001 0011100i didn't make up this form of encryption, but i like it.credit to the lvl 6 challenge on arcanum.co.nz

Share this post


Link to post
Share on other sites

format?! screw that. it's not THAT serious yet is it? try doing a repair first, or install an older version of IE over your current one, then update it... sorry, format i think should be the last last last resort.

***edit***

oh yeah, you CAN navigate to websites from the run prompt, you know that right? press windows+R to get run box and type in an address http://google.com and it will go there...

i don't use IE as browser.. i only need it for view folders.

i have tried everythink... install IE SP1 didn't work because i have the IE update.. have to hack the registry but then the install just fails for some reason.

i did sfc /scannow ... nothing

get my self a program that should repair the adress bar... nothing

went to the control panel ... xp components... uninstall IE didn't work

i think it might the a control of windows or vb6 runtime... but well i don't know what to do...

just got to wait until format and the address bar will comeback lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0