Sign in to follow this  
Followers 0
jpm

Autoit-gui 102.23 Before Insertion In Unstable

10 posts in this topic

I upload the 102.23 version in http://www.hiddensoft.com/fileman/users/jpm/Misc/

just before integrate it in unstable

that's the following change/fix

main modif is the suppression of * in GuiSetControlData you have to change you code to use default parameter.

Fixed : Drag'drop on a tab control (Thanks CyberSlug).

Changed : No more '*' inside GuiSetControlData. Use default parameter.

Added : Pic control can be updated with GuiWrite. (Thanks CyberSlug)

Fixed : GuiSetControlEx($ref,$GUI_FOCUS). (Thanks CyberSlug)

Fixed : GuiRead($listref) or combo crash. (Thanks steve8tch)

Fixed : "date" control under Win2000 or Win9x. (Thanks Josbe)

Fixed : Tooltip update in Win9x (Thanks pekster)

Fixed : Click on input/button (Thanks Valik)

Added : Opt("GuiResizeMode",$mode) (Thanks CyberSlug)

Added : GuiSetCursor to change cursor display

Added : GuiGetControlState return all states

Thanks for testing :D

Share this post


Link to post
Share on other sites



JP, it looks like the AutoItSC.bin you provided is built in debug mode. I get an assertion when I run it sometimes.

---------------------------

Microsoft Visual C++ Debug Library

---------------------------

Debug Assertion Failed!

Program: ...y Programs\AutoIt Scripts\Au3 Interpreter\Au3 Interpreter.exe

File: fopen.c

Line: 54

Expression: *file != _T('\0')

For information on how your program can cause an assertion

failure, see the Visual C++ documentation on asserts.

(Press Retry to debug the application)

---------------------------

Abort Retry Ignore

---------------------------

What's odd is that I'm not trying to open a file at any point on this particular branch of my program.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

JP, it looks like the AutoItSC.bin you provided is built in debug mode.  I get an assertion when I run it sometimes.

What's odd is that I'm not trying to open a file at any point on this particular branch of my program.

My goodness. I wil correct and reupload.

Sorry for the trouble :D

Edit: done 23A

Edited by jpm

Share this post


Link to post
Share on other sites

Thanks JP, it's working now. Very happy to see the button click issue gone.

Share this post


Link to post
Share on other sites

Thanks JP, it's working now.  Very happy to see the button click issue gone.

Thanks,

You can use unstable same code from my point of view :D

Share this post


Link to post
Share on other sites

Perf is improving

Perf improvement 3.0.101.0 -> 3.0.102.0 (2004\05\17 23:21)

For=-3.77% Do=-4.83% While=-4.17% Include=-8.07%

very good JON

Share this post


Link to post
Share on other sites

:D yeah, a lot of corrections! :huh2:

Merci.

I hope we will not need too many next time.

Just test again :)

Share this post


Link to post
Share on other sites

Perf is improving

Perf improvement 3.0.101.0 -> 3.0.102.0 (2004\05\17 23:21)

For=-3.77% Do=-4.83% While=-4.17% Include=-8.07%

very good JON

No idea why....

I've not put in the binary search code yet for user and built-in functions - I want to make sure they aren't bugged first - but that should have a pretty cool speed increase in large programs.

Share this post


Link to post
Share on other sites

No idea why....

I've not put in the binary search code yet for user and built-in functions - I want to make sure they aren't bugged first - but that should have a pretty cool speed increase in large programs.

certainly Eurovision :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0