Sign in to follow this  
Followers 0
MrBeatnik

Controlsend/winwait Vs Winstate (hide) Problems

5 posts in this topic

Hello all, thanks for the help I've been getting so far.

I've got another small problem.

XP SP2, AutoIt v3 latest (not beta, but beta available).

I'm using ControlSendPlus to send commands to a particular CMD shell window.

WinWait is used to look for the title of the window (Opt("WinTitleMatchMode", 3) set).

Everything is great, and works fine when the CMD window is displayed on the screen.

However, when I set the WinState of this CMD box to HIDE, then there seems to be problems sending the commands to the window, or waiting on the WinWait - I'm not sure which part it's having an issue with just now. I am aware that controlsend has issues when dealing with command windows (well, at least that's what I keep reading), so I wonder if this is one of those problems?

Does anyone know if this is a limitation, or if a workaround exists to ensure controlsends/winwaits "work" with Hidden Window states? For example, I was working with WinWaitActive for a little while, but obviousuly that is irrelevant to HIDDEN windows, where they would never be active, so that is an obvious limitation there... I guess!

Thanks!


Please correct me if I am wrong in any of my posts. I like learning from my mistakes too.

Share this post


Link to post
Share on other sites



instead of hidden, is off screen ok? move the window.

Lar.

Hehe, now that would work!

Thanks! Time for a time-out from this code I think.... that was too easy an answer for ya :)

Thanks for the quick reply too!

Just for academic purposes, I presume that is a known limitation then? No sends (or is it winwaits) on hidden windows?


Please correct me if I am wrong in any of my posts. I like learning from my mistakes too.

Share this post


Link to post
Share on other sites

Hehe, now that would work!

Thanks! Time for a time-out from this code I think.... that was too easy an answer for ya :)

Thanks for the quick reply too!

Just for academic purposes, I presume that is a known limitation then? No sends (or is it winwaits) on hidden windows?

The mouse does not go outside the viewable screen area as you may comprehend as such.

Share this post


Link to post
Share on other sites

The mouse does not go outside the viewable screen area as you may comprehend as such.

??????

Limitation referring to the HIDDEN window and CONTROLSEND command :)


Please correct me if I am wrong in any of my posts. I like learning from my mistakes too.

Share this post


Link to post
Share on other sites

...Just for academic purposes, I presume that is a known limitation then? No sends (or is it winwaits) on hidden windows?

"Sends" actually seem to work when sent to the hidden window mentioned in this post:

http://www.autoitscript.com/forum/index.php?showtopic=24733

...but that is not the norm.


[size="1"][font="Arial"].[u].[/u][/font][/size]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0