Sign in to follow this  
Followers 0
Sardith

Question

7 posts in this topic

#1 ·  Posted (edited)

Few things, this is my second big script.. First time using GUI's so...

Anyways When I click my buttons it doesn't do the "Else" it doesn't bring up the Msgbox.. Could someone please help me?

Edited by Sardith

[font="Verdana"]Valik:Get it straight - I'm not here to say please, I'm here to help - if my help's not appreciated then lotsa luck, gentlemen.[/font]

Share this post


Link to post
Share on other sites



Anyways When I click my buttons it doesn't do the "Else" it doesn't bring up the Msgbox.. Could someone please help me?

and the window doesn't exists ?


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Eh? The Msg box doesn't create when there's no client running. Run the program, it should make a message box with out the game Fear running in the background.


[font="Verdana"]Valik:Get it straight - I'm not here to say please, I'm here to help - if my help's not appreciated then lotsa luck, gentlemen.[/font]

Share this post


Link to post
Share on other sites

Eh? The Msg box doesn't create when there's no client running. Run the program, it should make a message box with out the game Fear running in the background.

Did you check the value of $WinH ?

It will return "" when the window doesn exists..

So then the WinExists("") will always be true .....


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Im sorta lost, Value? The Help file didn't really help either..

Edit: Got it thanks.

Edited by Sardith

[font="Verdana"]Valik:Get it straight - I'm not here to say please, I'm here to help - if my help's not appreciated then lotsa luck, gentlemen.[/font]

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Im sorta lost, Value? The Help file didn't really help either..

Try debugging your script by putting consolewrite() or msgbox() statements in your source to verify the content of variables.

As said this statement will set $WinH to ""

Dim $WinH = WinGetHandle( "Fear")

then when you do :

If WinExists($WinH) Then

you actually do test:

If WinExists("") Then

I leave the rest to you to sort out.... :)

Edited by JdeB

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Yeah, had it figured out 5mins back. Silly mistake even when I'm trying to keep my code very neat.


[font="Verdana"]Valik:Get it straight - I'm not here to say please, I'm here to help - if my help's not appreciated then lotsa luck, gentlemen.[/font]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0