Sign in to follow this  
Followers 0
Rraney

_ieformimageclick() Use?

9 posts in this topic

How does one use the '_IEFormImageClick()' in <IE.au3> ?

here is an example page source I have.

<a title=" Next " style="font-family:tahoma;font-color:#900000;font-size:11px;" href="java script:nextpage('2')"><img src="images/home_next.jpg" border="0" align="top"></a>

and I would like to have it click on the next.jpg button.

What I have used, and failed is:

_IEFormImageClick ( $oIE, "home_next.jpg", "name")

and all I get back is

>Running:(3.1.1.122):C:\Program Files\AutoIt3\beta\autoit3.exe "C:\Documents and Settings\rsr\Desktop\devappTest1.au3"  
--> IE.au3 Warning from function _IEFormImageClick, $_IEStatus_NoMatch

Share this post


Link to post
Share on other sites



The requested 'try' failed.

With

_IEFormImageClick ( $oIE, "home_next.jpg") ; or

_IEFormImageClick ( $oIE, "images/home_next.jpg")

oÝ÷ Ø-Y`z×(uî¶Féçx9ó7×]vÛyð.|ÓÝ®+jabë4÷`.-ßOvmëZÓݺÚ"·w±{~çÍ=Ø:ºg§¶Æ§u'­¶)à³Ov²§z½=Ø7¬Ú)Óݦj)Z»}øýÊy(Zꮢקjg

"name" does not work... its an "src"

8)

Share this post


Link to post
Share on other sites

How does one use the '_IEFormImageClick()' in <IE.au3> ?

here is an example page source I have.

<a title=" Next " style="font-family:tahoma;font-color:#900000;font-size:11px;" href="java script:nextpage('2')"><img src="images/home_next.jpg" border="0" align="top"></a>
Wrong function.

_IEFormImageClick() is for <input type="image" elements. You want _IEImgClick() instead.

Dale

1 person likes this

Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

>Running:(3.1.1.122):C:\Program Files\AutoIt3\beta\autoit3.exe "C:\Documents and Settings\rsr\Desktop\devappTest1.au3"  
--> IE.au3 Warning from function _IEFormImageClick, $_IEStatus_NoMatch

I still get

>Running:(3.1.1.122):C:\Program Files\AutoIt3\beta\autoit3.exe "C:\Documents and Settings\shaner\Desktop\mail.au3"

- Shane

those are two completely different errors... and from two different files

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Sorry, this is what happens when I try to post something when Im close to falling over in RL from lack of sleep. I renamed the file to keep my orginal, my stupidity for not changing the file name in error post here to reflect the same file name.

I'll post the full error later today if it happens.

- R Shane

those are two completely different errors... and from two different files

8)

Share this post


Link to post
Share on other sites

Sorry, this is what happens when I try to post something when Im close to falling over in RL from lack of sleep. I renamed the file to keep my orginal, my stupidity for not changing the file name in error post here to reflect the same file name.

I'll post the full error later today if it happens.

- R Shane

Before you post the script, make certain that you read my reply 3 back.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Thank you! That worked.

Wrong function.

_IEFormImageClick() is for <input type="image" elements. You want _IEImgClick() instead.

Dale

Share this post


Link to post
Share on other sites

Wrong function.

_IEFormImageClick() is for <input type="image" elements. You want _IEImgClick() instead.

Dale

saved my life again. thanks dale :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0