Sign in to follow this  
Followers 0
duketrapp

Why "no Reply" Window When Click On Transparent Window?

6 posts in this topic

#1 ·  Posted (edited)

I use a blocking window in my script (to avoid user click on buttons while a wav file plays..)

Code looks like that:

Func playwav($val,$duration)

$winpos = WinGetPos ( $scriptname );<- $scriptname is  ur main gui
$SAFE = GUICreate('')
GUISetState( $WS_EX_TRANSPARENT, $SAFE)
$VAULT = GUICreate("avoider", $winpos[2], $winpos[3], $winpos[0], $winpos[1], -1, -1, $SAFE)
WinSetOnTop("avoider", "", 1)
WinSetTrans("avoider", "", 1)
GUISetState()
    
SoundPlay ( $wavsspath & $val & ".wav", $duration)
    
GUIDelete($VAULT)
GUIDelete($SAFE)
    
Return
EndFunc

all works great and perfect..but sometimes when i make a few clicks on the blocking trans window, i see ~500 milliseconds a non trans window with the phrase "no reply" in the header ( the message u get in window title when a program is freezed).. than after the milliseconds all runs normal and window turn back to transparency...

i dont know if its an error by the blocking script or a general overflow on input when u clicking on an transparent window when a wav plays... maybe someone knows why this happends or how i can avoid this "no reply" window from coming up...

salute...

Edited by duketrapp

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

to disable the GUI use this

GUISetState(@sw_diable , $GUI)oÝ÷ ÚÚÆë(æî¶Ú'²ëjëh×6GUIctrlsetstate( $Button , $GUI_DISABLE )

Do you realy need this blocking window?

Edited by rbhkamal

"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites

to disable the GUI use this Code: AutoItGUISetState(@sw_diable , $GUI)

to disable some buttons use Code: AutoItGUIctrlsetstate( $Button , $GUI_DISABLE )

Do you realy need this blocking window?

then it will beep when clicked

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

then it will beep when clicked

8)

How about he switchs the onEventmode between 1 and 0 this way the GUI will not listen to anything? Edited by rbhkamal

"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites

How about he switchs the onEventmode between 1 and 0 this way the GUI will not listen to anything?

that might just work... good idea

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

@duketrapp

All what you have to do it this:

1-Use this line at the top of your function

$Mode_Backup = Opt( "GUIOnEventMode" , 1);Change 1 to 0 if you are already using it.
oÝ÷ Û`^~Þʺw-ì­ën®{2¢ë!¢é]ºÇ­+-¢·¬¶Þ¶¬zÛbºÚ"µÍÜ
    ][ÝÑÕRSÛ][[ÙI][ÝÈ    ÌÍÓ[ÙWÐXÚÝ
B

But I don't know why you get that " No reply" thing. sorry


"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0