Sign in to follow this  
Followers 0
marfdaman

Freezing Sliders

3 posts in this topic

#1 ·  Posted (edited)

Hello, for some odd reason the two sliders in my program will freeze not even a second after you "touch" it:

they move fine for an instant, and then suddenly they can't be moved anymore, at least, you don't see them moving any more, because it will still update the sound volume but not the graphic of the sliding (do you follow me?). The code is attached, it's just a little lengthy (+/- 3100 lines).

Please give me some hint as to what might be causing this. :)

Edit: should have posted this in GUI forum...sorry...

Regards

Edited by marfdaman

Don't take my pic to serious...~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~You Looked, but you did not see!~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites



this is why

While 1
    _while()
WEnd

you are calling a function over and over and ....

inside that function you are calling othger functions over and over and....

you cant do that

you should place that _while function and the gutmessage function inside the wHile / wend loop

8)

btw OVERALLL.. NICE JOB!!!

Valuater


NEWHeader1.png

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

this is why

While 1
    _while()
WEnd

you are calling a function over and over and ....

inside that function you are calling othger functions over and over and....

you cant do that

you should place that _while function and the gutmessage function inside the wHile / wend loop

8)

btw OVERALLL.. NICE JOB!!!

Valuater

Tnx for your help, but that's not the problem (actually, that's what's saving my script from using ~50% cpu all the time due to I think a large amount of code being executed all the time, so guigetmsg's auto relaxing is quite useless :) , have been using that way for quite a long time already and never had any problems with it.

What IS causing this however, is, as I just found out, gafrost's way to handle a doubleclick in a listview, because when I take

GUIRegisterMsg($WM_NOTIFY, "WM_Notify_Events")

out of my script, everything works like it should!

I'm a little disappointed about this, 'cause this ruins my doubleclick-to-play feature, but I guess there's no other option.

Tnx for your compliment!

Regards

Edited by marfdaman

Don't take my pic to serious...~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~You Looked, but you did not see!~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0