Sign in to follow this  
Followers 0
JohnnyR

Feature Working before compile, but not after?

5 posts in this topic

Hi gys, I need a little assistance. I have a status bar at the bottom of my GUI. It works great before compiling. After however, it becomes hidden except for the first letter. Any Ideas?

$statuslabel = GUICtrlCreateLabel ("Ready",0,388,303,23,BitOr($SS_SIMPLE,$SS_SUNKEN))

Is what I have for the label...But I just dont understand why it would work before compiling, but not after?

Thanks,

John

Share this post


Link to post
Share on other sites



Works for me. (Beta 3.1.1.124)

#include <GuiConstants.au3>
HotKeySet("ESC", "Terminate")
Local $form = GUICreate("TEst", 200, 200)
Local $statuslabel = GUICtrlCreateLabel ("Ready",10,180,175,23,BitOr($SS_SIMPLE,$SS_SUNKEN))
GUISetState(@SW_SHOW)
While GUIGetMsg() <> - 3
WEnd
Exit
Func Terminate()
   Exit
EndFunc

Could you post some more code?

Share this post


Link to post
Share on other sites

Works for me. (Beta 3.1.1.124)

#include <GuiConstants.au3>
HotKeySet("ESC", "Terminate")
Local $form = GUICreate("TEst", 200, 200)
Local $statuslabel = GUICtrlCreateLabel ("Ready",10,180,175,23,BitOr($SS_SIMPLE,$SS_SUNKEN))
GUISetState(@SW_SHOW)
While GUIGetMsg() <> - 3
WEnd
Exit
Func Terminate()
   Exit
EndFunc

Could you post some more code?

Well, I didn't want to post my entire program, I may have to. What im really looking for is what changes between non-compiled and compiled. What could cause this?

If you can't help me with just that info, its no problem. I'm just perplexed as to why it would work before compiling but not after?

Share this post


Link to post
Share on other sites

as Uten stated it should work..

we would need to see your code to look for any relation to that line or other error that would cause a problem

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

as Uten stated it should work..

we would need to see your code to look for any relation to that line or other error that would cause a problem

8)

Ok, well Valuator, I'm going to PM you the code, because I know your a trusted member here =)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0