Sign in to follow this  
Followers 0
tutui

FileFindFirstFile () problem

4 posts in this topic

hi,

I have a strange behaviour with the filefindfirstfile () funtion. maybe someone can help me with that issue...

what I want do to? I want to find every "*.log" files in a special directory, let's say this directory is c:\temp. in this directory I have this files:

0000.log

0001.log

0002.log_lix

0003.log_jix

I assumed that when I do the following:

$search = FileFindFirstFile ("*.log")

I'll just get a search handle to the "*.log" files and not to the "*.log_*" files. but in fact when I later go trough the search handle $search with

$file_log = FileFindNextFile($search)

I also get the "0002.log_lix" and "0003.log_jix"!

did I miss something at this point? can someone give me a clue? it seems to me like it is totally unlogical to get this file within the search handle...

thanks.

peace,

tutui.

Share this post


Link to post
Share on other sites



Looks like a bug.

-mu

Share this post


Link to post
Share on other sites

it was my first thought too...

anyone else?

peace,

tutui.

Share this post


Link to post
Share on other sites

Does seem like a bug.

The topic posted in the Bug Forum should be enough. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0