Sign in to follow this  
Followers 0

install issue

2 posts in this topic

#1 ·  Posted (edited)

i am having problems scripting the install of:

The focus shifts between various windows during install. I think autoit is getting lost. I am using keystroke driven navigation. Also Autoit3 doesnt appear to ever find the popup that "create a shortcut on desktop".

I am trying to build a big script to install about 30 applications on a new pc. from Office to windows service packs, etc.

The keystroke method appears to be highly unreliable. Is this a correct observation, or am i doing something wrong.

I have resorted to using a routine i call the focusHammer.




until winactive("asdf",qwer")


This doesn't hang, but doesn't always work.

Can someone post a tutorial on how to use the mouse input method. I used it, but if the window loses focus durung a script run the mouse clicks are erratic. Again using a similar method to assure the focus is in the window before doign the action. This is going to be perfomed in an office environment with quite a few nieve users that will freak when they see the script running... even if i tell them before hand. they will go wiggling the mouse and break the script. The script fails enough on its own

is there a better way?

Edited by maaltan

Share this post

Link to post
Share on other sites

Most have options to do installs from the command line or have the ability to use "ControlClick() (In the help file)".

[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0