Sign in to follow this  
Followers 0
Fabio-84

Hidden Button Click

3 posts in this topic

I want to create an script for a Free Antivirus Programm.

If Not WinActive("Avira AntiVir PersonalEdition Classic","Annehmen") Then WinActivate("Avira AntiVir PersonalEdition Classic","Annehmen")

WinWaitActive("Avira AntiVir PersonalEdition Classic","Annehmen")

ControlClick("Avira AntiVir PersonalEdition Classic", "Annehmen", 1)

WinWait("Avira AntiVir PersonalEdition Classic","Setup of AntiVir Wor")

If Not WinActive("Avira AntiVir PersonalEdition Classic","Setup of AntiVir Wor") Then WinActivate("Avira AntiVir PersonalEdition Classic","Setup of AntiVir Wor")

WinWaitActive("Avira AntiVir PersonalEdition Classic","Setup of AntiVir Wor")

ControlClick("Avira AntiVir PersonalEdition Classic", "Fertig stellen", 12325)

The First Controlclick works really fine.

But when I'm tryin to click on "Fertig stellen" button with ID 12325 than nothing happens.

Auto it Info tells me that the button is "hidden" -> but i can see a Button with Label "next".

What could be the problem ?

Share this post


Link to post
Share on other sites



Try Control Show... and I don't know if Fertig stellen means Next but you might want to try this if not:

ControlClick("Avira AntiVir PersonalEdition Classic", "Next", 12325)
Or
ControlClick("Avira AntiVir PersonalEdition Classic", "&Next", 12325)
Or
ControlClick("Avira AntiVir PersonalEdition Classic", "", 12325)


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

thanks for your really fast answer !

I wil try it !

ok here are 2 screenshots. to click on "Abbrechen" is no problem - > But i want to click on "weiter" =next

autoit shows no Info for the "weiter" button (screenshot)

for my understanding:

Controll is hidden -> Is there a Button on top of "Weiter" Button which is hidden? ->

The Button weiter is not "hidden" for me - I can see it. But Autoit Info can't.

Why is this so ?

It would be really kind if you could explain me a little bit the problem and tell me a solution.

I tryed to go next with "space" button - > this works -> but it's not the solution i want.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0