Sign in to follow this  
Followers 0
luvmachine

Run() cmd messing up another program

6 posts in this topic

Okay, so basically if I double click the icon for the program it runs fine. However when I use the Run() command to run this program it causes the program to not work properly. And I don't just mean a little off, I mean I don't even get proper characters and it doesn't even work slightly how its supposed to. Now, I tried going into Command Prompt and using "start 'location'" to run the program and it did the same thing, so I assume that when AutoIt does a Run() it uses that.

I guess my question is: Does anyone know another way to Run a program with AutoIt that won't go through DOS to run it? Because Window's run.exe ran it fine.

Thank you

Share this post


Link to post
Share on other sites



if you post the program name and your efforts...

then we can help

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

The program is called NPC. However it won't work for most people, it scans Memory locations while your running Final Fantasy XI to show the NPCs that are spawned near you.

http://www.luvmachine.org/files/NPC.exe incase you want to check it out. However it is a potentially bannable offense through Play Online so don't use it if your running FFXI and not willing to take the risk.

As for my efforts? I pretty much said what I had tried :D If I can't get it to work though its not the end of the world, just means I can't be as lazy.

Share this post


Link to post
Share on other sites

ok.. where is it on your computer

example

program files\npc\npc.exe

or

in the script directory ( need location )

or

????

8


NEWHeader1.png

Share this post


Link to post
Share on other sites

some speech...

8

HA! you missed the ")" ^^

Just noticed this :D


--------------------------------------------------------------------------------------------------------------------------------Scripts : _Encrypt UDF_UniquePCCode UDF MS like calculatorInstall programm *UPDATED* --------------------------------------------------------------------------------------------------------------------------------[quote name='Helge' post='213117' date='Jul 26 2006, 10:22 AM']Have you ever tried surfing the internet with a milk-carton ?This is similar to what you're trying to do.[/quote]

Share this post


Link to post
Share on other sites

Oh, my bad, the location on my computer is:

C:\Documents and Settings\Luvmachine\Desktop\NPC.exe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0