Sign in to follow this  
Followers 0
NightGaunt

Issue with Controlsend

2 posts in this topic

#1 ·  Posted (edited)

Have not been here in a while, but I guess when I need help I come crawling on back...

Here is the issue

$pWORA = ('W{ASC 058}\Ora01.102.en.001\dba\oracle.cmd{Enter}')
    Runwait(@ComSpec & ' /c Start "foo"',@SystemDir, @SW_HIDE)
    Winwait("foo","")
    WinSetState("foo","",@SW_HIDE)
    Controlsend("foo","","",$pWORA)

That is a piece of the code I am using. The issue I have is this. My control send works fine in the US, but in Japan it fails ASCII issue.

Now if I try to use a Send I run the risk of user interferance and I am forbidden by the client to stop the users from messing around. But if I control send the : key it comes up as a ; in the dos window. I tried setting the control send to 1, no effect. I tried using the {:} idea, no effect. And I tried the {Shiftdown} ; , no effect.

So does anyone know a way I can solve this issue? My first thought was sending the information to a text document, but I run in to a similar character issue because of the Japanese machines.

Edited by NightGaunt

"I have discovered that all human evil comes from this, man's being unable to sit still in a room. " - Blaise Pascal

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Does it work if you do this, probly wont change it though

$ComSpec = @ComSpec
    $pWORA = ('W{ASC 058}\Ora01.102.en.001\dba\oracle.cmd{Enter}')
    Runwait($ComSpec & ' /c Start "foo"',@SystemDir, @SW_HIDE)
    Winwait($ComSpec,"")
    WinSetState($ComSpec,"",@SW_HIDE)
    Controlsend($ComSpec,"","",$pWORA)

Prolly wont make a difference, but, Who knows xD

Edited by AzKay

# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0