Sign in to follow this  
Followers 0
Klaatu

Consistency in internal function naming

1 post in this topic

It seems as if the AutoIt developers are trying to have consistency in the naming of internal functions, which is a laudable goal. All the file manipulation funtions start with 'File', and all the GUI functions start with 'GUI'. Sounds great so far.

But does it go far enough? For example, it's FileOpen and FileClose, but UDPOpen and UDPCloseSocket?

And how about the TCP functions? TCPConnect instead of TCPOpen? And again TCPCloseSocket; why the word Socket there? That'd be like making it FileOpen in one case, but FileCloseHandle in the other.

Anyway, those are the ones I noticed. Anyone else with other examples?


My Projects:DebugIt - Debug your AutoIt scripts with DebugIt!

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0