Jump to content
Sign in to follow this  
Guest sbducker

Run command, Now you see it, now you don't

Recommended Posts

Guest sbducker

extreme newbie here, sorry if this is a softball question. I had complied a script that launched an outside application.

I used the command Run("myfilename.exe","c:",@sw_maximize)

or something very similar.

It worked beutifully...for a few hours.

Then I started to get errors:

"Error: Unable to execute the external program."

"The system Cannot find the File specified"

I Checked, and it was still there. I used the sample run command (notepad.exe) from the read me, and it worked.

OK, follow closes here, I located the Notepad.exe @ C:. Still worked. I deleted that version of notepad, and renamed myfile.exe to notepad.exe.

When I ran the script it launched Notepad still! (not myfile) Strange?

I rebooted, and ran the script again, and still launched Notepad! Where is it coming from?

Has anyone seen anything similar?

Share this post

Link to post
Share on other sites
Guest sbducker

I also attempted to use the @comspec method and still no success. From the C-prompt I can run Myfile.exe by typing "myfile" so it is there and operational.

Share this post

Link to post
Share on other sites





You don't have to use @ComSpec to start .exe files

@ComSpec is the command.com or cmd.exe. Depends on the OS.

These are Interpreters to run batchfiles.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.