Sign in to follow this  
Followers 0
rbhkamal

!>AutoIT3.exe ended.rc:-1073741819

10 posts in this topic

#1 ·  Posted (edited)

Does anyone know what this error means:

>Error code: 0
!>AutoIT3.exe ended.rc:-1073741819
>Exit code: -1073741819 Time: 146.046

I have a script that crashes 'autoit.exe' each once and while and I don't know why.

Can someone please give me a hint on what that error stands for?

Note:

This script depends on IE.au3

AutoIt V3.2.0.1

WIN XP SP2

Two Static NICs

Thanks

RK

Edited by rbhkamal

"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Does anyone know what this error means:

>Error code: 0
!>AutoIT3.exe ended.rc:-1073741819
>Exit code: -1073741819 Time: 146.046

I have a script that crashes 'autoit.exe' each once and while and I don't know why.

Can someone please give me a hint on what that error stands for?

Note:

This script depends on IE.au3

AutoIt V3.2.0.1

WIN XP SP2

Two Static NICs

Thanks

RK

Are there any plugins involved? I have had the same output before, but it was mainly because my plugin was failing, and causing a hard AutoIt crash.

Also you may want to try the newest beta. AutoIt v3.2.1.1 (I dont think this would help, but you never know.)

JS

Edited by JSThePatriot

AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

No. I don't have any plugins.

RK


"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

I just need to make sure that everyone knows that this problem is not consistent.

RK

Edited by rbhkamal

"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites

I just need to make sure that everyone knows that this problem is not consistent.

RK

Then there may be some sort of memory leak in the stable release. See if you can get it to consistantly show up by doing certain things.

Also try, as I later added to my above post, the newest beta.

:P

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Then there may be some sort of memory leak in the stable release. See if you can get it to consistantly show up by doing certain things.

Also try, as I later added to my above post, the newest beta.

:P

JS

Sure, but that might take me while because I'm at work now.

Thanks

RK

Edit:

Here is the full script:

Edit:I removed the attachment to save space

This is the INI file:

[Settings]
TCP_Port=1023
Client_Enabled=False
[MC_Params]
MY_IP=192.168.100.147
MC_IP=192.168.100.2
MC_UserName=***
MC_Password=*****
Policy_Name=Mesh STS_2
MC_Telnet_array[0][0]=0
MC_Telnet_array_UBound(2)=3
Disables[0]=False
Disables[1]=True
Disables[2]=False
Disables[3]=True
Disables[4]=True
Disables[5]=False
Disables[6]=False
Disables[7]=False
Disables[8]=False
Disables[9]=True
Disables[10]=False
Disables[11]=False
Disables[12]=False
Disables[13]=False
Disables[14]=False
Disables[15]=False
Disables[16]=False
Disables[17]=False
Disables[18]=False
Disables[19]=False
Disables[20]=False
Disables[21]=False
Disables[22]=True
Disables[23]=False
Disables[24]=False
Disables[25]=False
Disables[26]=False
Disables[27]=False
Disables[28]=False
Disables[29]=True
Disables[30]=False
MC_exceptions[0][0]=4
MC_exceptions[1][1]=-1
MC_exceptions[1][2]=ESP_DES
MC_exceptions[1][3]=-1
MC_exceptions[1][4]=-1
MC_exceptions[1][5]=NonOrdering
MC_exceptions[2][1]=-1
MC_exceptions[2][2]=ESP_DES
MC_exceptions[2][3]=-1
MC_exceptions[2][4]=-1
MC_exceptions[2][5]=Ordering
MC_exceptions[3][1]=-1
MC_exceptions[3][2]=ESP_TDES
MC_exceptions[3][3]=-1
MC_exceptions[3][4]=-1
MC_exceptions[3][5]=Ordering
MC_exceptions[4][1]=-1
MC_exceptions[4][2]=ESP_TDES
MC_exceptions[4][3]=-1
MC_exceptions[4][4]=-1
MC_exceptions[4][5]=NonOrdering
Edited by rbhkamal

"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites

Sure, but that might take me while because I'm at work now.

Thanks

RK

Edit:

Here is the full script:

This is the INI file:

[Settings]
TCP_Port=1023
Client_Enabled=False
[MC_Params]
MY_IP=192.168.100.147
MC_IP=192.168.100.2
MC_UserName=***
MC_Password=*****
Policy_Name=Mesh STS_2
MC_Telnet_array[0][0]=0
MC_Telnet_array_UBound(2)=3
Disables[0]=False
Disables[1]=True
Disables[2]=False
Disables[3]=True
Disables[4]=True
Disables[5]=False
Disables[6]=False
Disables[7]=False
Disables[8]=False
Disables[9]=True
Disables[10]=False
Disables[11]=False
Disables[12]=False
Disables[13]=False
Disables[14]=False
Disables[15]=False
Disables[16]=False
Disables[17]=False
Disables[18]=False
Disables[19]=False
Disables[20]=False
Disables[21]=False
Disables[22]=True
Disables[23]=False
Disables[24]=False
Disables[25]=False
Disables[26]=False
Disables[27]=False
Disables[28]=False
Disables[29]=True
Disables[30]=False
MC_exceptions[0][0]=4
MC_exceptions[1][1]=-1
MC_exceptions[1][2]=ESP_DES
MC_exceptions[1][3]=-1
MC_exceptions[1][4]=-1
MC_exceptions[1][5]=NonOrdering
MC_exceptions[2][1]=-1
MC_exceptions[2][2]=ESP_DES
MC_exceptions[2][3]=-1
MC_exceptions[2][4]=-1
MC_exceptions[2][5]=Ordering
MC_exceptions[3][1]=-1
MC_exceptions[3][2]=ESP_TDES
MC_exceptions[3][3]=-1
MC_exceptions[3][4]=-1
MC_exceptions[3][5]=Ordering
MC_exceptions[4][1]=-1
MC_exceptions[4][2]=ESP_TDES
MC_exceptions[4][3]=-1
MC_exceptions[4][4]=-1
MC_exceptions[4][5]=NonOrdering
I get no errors, but at the same time I am not sure what I am supposed to do with this program. I ran it under 3.2.0.1 no problems from SciTE.

Let me know how to better test it,

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

I get no errors, but at the same time I am not sure what I am supposed to do with this program. I ran it under 3.2.0.1 no problems from SciTE.

Let me know how to better test it,

JS

Here are the steps to recreate the problem using SciTe:

1- From Scite press F5

2- When the program opens up, click on the File menu --> load then select the ini file.

3- Click OK

4- Click on the Edit menu -- > Set parameters ---> MC

5- Click OK

6- Click on the Actions menu ---> Start

The crash is happening near the time of creating the IE window.

Let me know if you have any questions.

Note:

This script was created to automate a very long test for web server.

RK

Edited by rbhkamal

"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites

Here are the steps to recreate the problem using SciTe:

1- From Scite press F5

2- When the program opens up, click on the File menu --> load then select the ini file.

3- Click OK

4- Click on the Edit menu -- > Set parameters ---> MC

5- Click OK

6- Click on the Actions menu ---> Start

The crash is happening near the time of creating the IE window.

Let me know if you have any questions.

Note:

This script was created to automate a very long test for web server.

RK

Don't see the _IEErrorHandlerRigister()... howare you handling Com errors ?

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Don't see the _IEErrorHandlerRigister()... howare you handling Com errors ?

When I first made this script it was depending on T1.0 version of IE.au3 and I didn't want to make major changes to the code when T2.0 was included in the install package; so I just left the error handling for IE.au3.

Could that be the problem?

I will try to use _IEErrorHandlerRigister() and see what type of COM errors I get.

But that doesn't make sense to me, why I don't see the problem in the beta version?

RK


"When the power of love overcomes the love of power, the world will know peace"-Jimi Hendrix

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0