Sign in to follow this  
Followers 0
Olish

RunExeSvc... "The specified service already exists..."

10 posts in this topic

Hi everybody ? Fine ?

I'm trying to execute an EXE as a service with RunExeSvc.

And I tried on my PC and on a newly installed PC. But I have this message :

Error 1073 : The specified service already exists

Do someone already had this problem please ?

Thank you !


Olivier, from France.Free Wake On LAN script

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

a screenshot could help post it please.

Edited by aceloc

[quote name='AceLoc']I gots new sunglasses there cool.[/quote]

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Here is the screen capture of RunExeSvcAdmin.exe and the test.exe...

test.zip

Edited by Olish

Olivier, from France.Free Wake On LAN script

Share this post


Link to post
Share on other sites

That's truly funny... and how do you expect us to debug that?


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

That's truly funny... and how do you expect us to debug that?

indeed.

[quote name='AceLoc']I gots new sunglasses there cool.[/quote]

Share this post


Link to post
Share on other sites

Sorry, I just added the test.exe in the zip file... :s

You must run RunExeSvcAdmin.exe and click New to have the GUI attached.


Olivier, from France.Free Wake On LAN script

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Maybe can I simply add in win.ini :

[windows]
run=myfile.exe

to execute my program without logging.

What do you think about it ?

Edited by Olish

Olivier, from France.Free Wake On LAN script

Share this post


Link to post
Share on other sites

Yes, I know SrvAny. The problem is that I want to develop a free software. And there is a problem for the MS licence...

However, RunExeSvc is GPL !


Olivier, from France.Free Wake On LAN script

Share this post


Link to post
Share on other sites

Error 1073 : The specified service already exists

That may indicate that you must first uninstall the service before installing it again. Once it's installed, you run and stop it with Net Start or Net Stop from the command line, or use the Services control panel.


[font="Fixedsys"][list][*]All of my AutoIt Example Scripts[*]http://saneasylum.com[/list][/font]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0