Sign in to follow this  
Followers 0
AzKay

_IEFormElementCheckBoxSelect()

7 posts in this topic

$oIE = _IECreate("http://gaiaonline.com", 0, 1)
    $oForm = _IEFormGetCollection($oIE, 0)
    $UsernameValue = _IEFormElementGetObjByName($oForm, "username")
    _IEFormElementSetValue($UsernameValue, $Username)
    $PasswordValue = _IEFormElementGetObjByName($oForm, "password")
    _IEFormElementSetValue($PasswordValue, $Password)
    $CheckRememberMe = _IEFormElementGetObjByName($oForm, "autologin")
    _IEFormElementCheckBoxSelect($oForm, "", "autologin")

Ive been sitting here, way over 45minutes, and I cant get it to check the box xP.


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites



Bump.


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

*And all is still.*


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

Did you study the example in the helpfile? How id your situation different? Are there any messages being sent to the SciTe console?

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

I studied the helpfile, I compared the differences in the source, it returns, "$No_Match", Though, as far as I know, it should be matching.


# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

I studied the helpfile, I compared the differences in the source, it returns, "$No_Match", Though, as far as I know, it should be matching.

The No Match is significant. At the least it tells you where to focus your attention.

Please look at the examples again and study the parameters you are passing -- they don't look right.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Thanks. Got it :)

_IEFormElementCheckboxSelect ($oForm, "autologin", "", 1, "byIndex")

# MY LOVE FOR YOU... IS LIKE A TRUCK- #

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0