Sign in to follow this  
Followers 0
longisland

wow auto fishing bot---looking for ideas

4 posts in this topic

I've been working on a wow auto fishing bot for quite a few days already.

The problem I encountered was that in wow everything changes its color and position in screen. For example after casting the hook, the bubber is randomly dropped into water, and the bubber actually looks differently each time it is casted depending on the distance, lighting, weather etc.

My questions is, how to detect the bubber's location (under all lighting/weather conditions)

The next problem is how to detect when the fish is hooked. When hooked, the bubber vabrate, and a small splash appears randomly around bubber. Again, how to detect this event.

Any inputs? I was thinking going along the fishing string to look for bubber since the string has quite stable color. However, I still havn't worked out the splash part.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

I created a WoW bot that worked great a while ago. I no longer use it but it earned me a few hundred gold back in the day. Ill post it here and u can check out the code to see how I accomplished things.

Also, dont mind the messy code, this was created 3/4 of a year ago and I was still a bit of an autoit noob :lmao:

EDIT: I didnt realise that I was looking at the scrips and scraps section. I almost feel ashamed that I replied.

In the future, this is not a general support forum, do not ask for help here.

Fishbot.zip

Edited by ame1011

[font="Impact"] I always thought dogs laid eggs, and I learned something today. [/font]

Share this post


Link to post
Share on other sites

I created a WoW bot that worked great a while ago. I no longer use it but it earned me a few hundred gold back in the day. Ill post it here and u can check out the code to see how I accomplished things.

Also, dont mind the messy code, this was created 3/4 of a year ago and I was still a bit of an autoit noob :lmao:

EDIT: I didnt realise that I was looking at the scrips and scraps section. I almost feel ashamed that I replied.

In the future, this is not a general support forum, do not ask for help here.

Thank you very much

Share this post


Link to post
Share on other sites

does this still work? or did it work in the first place?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0