Sign in to follow this  
Followers 0
lgodfrey

Hotkey Directions for Crimson

7 posts in this topic

I'm a newbie (to autoit not programming/computers), downloaded AutoIT and Crimson, copied scripting info from Manual Install and Notes.htm

to tools in Crimson.

context help and run seem to work, but not compile. forum search found no answers.

When I "compile" from Crimson, I see a "flash" indicating some sort of fast window focus change, but no output file can be found, either using explorer or find {*.exe" or "filename*.*"}

Link to updated file in AutoIT help file doesn't seem to work to get any updated version if that is the problem:

http://www.hiddensoft.com/autoit3/files/Extra/

If others have problems, then maybe they can give me some advice about a fix.

If no one is having problems, then I have to go back and find the "typo" or other silly error.

PS I even used AutoIT window spy to grab the paths, to no avail, triple checked entries, looked in compile help to make sure Crimson instructions were compatible with help file compile method 3 .......nothing is obvious

Here's hoping!

Larry


I'm, Lovin' IT, X

Share this post


Link to post
Share on other sites



check out scite instead...  it's growing into the IDE of choice for autoit.

http://www.autoitscript.com/forum/index.php?showtopic=2839

The acronym "IDE" pretty much says it all. Crimson as well as most of the other editors found in the Extra's directory are just that, editors. But SciTE has proven that it's above that and is an actual integrated development environment (IDE) for AutoIt.

Share this post


Link to post
Share on other sites

I'm a newbie (to autoit not programming/computers), downloaded AutoIT and Crimson, copied scripting info from Manual Install and Notes.htm

to tools in Crimson.

context help and run seem to work, but not compile.  forum search found no answers.

When I "compile" from Crimson, I see a "flash" indicating some sort of fast window focus change, but no output file can be found, either using explorer or find {*.exe" or "filename*.*"}

Link to updated file in AutoIT help file doesn't seem to work to get any updated version if that is the problem:

http://www.hiddensoft.com/autoit3/files/Extra/

If others have problems, then maybe they can give me some advice about a fix.

If no one is having problems, then I have to go back and find the "typo" or other silly error.

PS I even used AutoIT window spy to grab the paths, to no avail, triple checked entries, looked in compile help to make sure Crimson instructions were compatible with help file compile method 3 .......nothing is obvious

Here's hoping!

Larry

I agree that Scite is a lot better than Crimson but if you insist on installing Crimson then you should have a look in the install directory of Autoit3 and look for this file: C:\Program Files\AutoIt3\Extra\Editors\Crimson\Manual Install and Notes.htm

It contains the basics for using AutoIt3 with Crimson....


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

ok, so AutoIT talks about Crimson and some other editors in the AutoIT help file, but these are now not the editors of choice. Would be nice if the help file was updated with new recommendations.

Thanks for your help, team, I will look at SciTE.

***********

Do I need any settings adjusted for it to work well with AutoIT such as the ones you need to do for Crimson?

*************

By the way, I am extremely impressed with the depth of windows controls. I can now add much more extensive error trapping than I ever thought I could, and since I am controlling financial transactions that sure is a big plus!!

JdeB, my first line says I already looked at this file. The problem is: its wrong for the compile part, or at least appears to be wrong.

Regards

Larry


I'm, Lovin' IT, X

Share this post


Link to post
Share on other sites

Hi Team, especially JdeB

Obviously my last question about special setup for scite would have been answered if I took the link to look at JdeB's installer that does the set up for AutoIT for you automatically. JdeB, you certainly saved me a lot of setup time, thanks.

Quick Look at scite and I can see why "you guys" were more interested in setting me on a path to scite rather than fixing crimson issues in help file (if indeed there are any other than the update link not working)

Thanks again, no reply expected.

Larry


I'm, Lovin' IT, X

Share this post


Link to post
Share on other sites

ok, so AutoIT talks about Crimson and some other editors in the AutoIT help file, but these are now not the editors of choice. Would be nice if the help file was updated with new recommendations.

The reason that Scite isn't in the helpfile yet is because we started the development of Scite's AutoIt3 Lexer after the official release of V3.

Jon mentioned he will put a download link on the Homepage and add it to the helpfile for the 102 release.

JdeB, my first line says I already looked at this file.  The problem is: its wrong for the compile part, or at least appears to be wrong.

Just for the record.. i also wrote the Crimson setup page and had a quick look at what i did.. the only thing i see wrong is that it contains a space but other than that it should work:

- Menu Text: AutoIT Compile Script
- Command: Your-AutoIt-Dir\ Aut2Exe\Aut2Exe
~~~~~~~~~~~~~~~~~~~~~~~~~~~^

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0