Sign in to follow this  
Followers 0
NTBM

Help! the help file doesnt work

8 posts in this topic

i have just installed AutoIT V3 onto a Windows 2003 server. when i press F1 nothing happens, no hourglass , no error message, and no help screen.

i presume the .chm files are the help files, so if i double click one of them i get an error msg "Cannot open the file: mk:@MSITStore:C:\program files\AutoIT3\AutoIt3.chm"

it is using "Microsoft HTML Help Executable" to open the file

Any ideas

Share this post


Link to post
Share on other sites



i have just installed AutoIT V3 onto a Windows 2003 server. when i press F1 nothing happens, no hourglass , no error message, and no help screen.

i presume the .chm files are the help files, so if i double click one of them i get an error msg "Cannot open the file: mk:@MSITStore:C:\program files\AutoIT3\AutoIt3.chm"

it is using "Microsoft HTML Help Executable" to open the file

Any ideas

Did you install using the Zip option or the Installer option?

[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

Did you install using the Zip option or the Installer option?

installer option.

i used the same on my XP machine and it worked fine. but not on my 2003 server

Share this post


Link to post
Share on other sites

Have you tried going through the Start Menu

Start>All Programs>Autoitv3>Beta>Help??


Infinity is a floorless room without walls or ceiling.Anyone who cannot cope with mathematics is not fully human. At best he is a tolerable subhuman who has learned to wear shoes, bathe, and not make messes in the house.

Share this post


Link to post
Share on other sites

Have you tried going through the Start Menu

Start>All Programs>Autoitv3>Beta>Help??

Certainly have.

i get nothing. not even an error or hourglass

Share this post


Link to post
Share on other sites

Tried reinstalling AutoIt, or restarting your computer (amazing how much that can fix sometimes)?


Infinity is a floorless room without walls or ceiling.Anyone who cannot cope with mathematics is not fully human. At best he is a tolerable subhuman who has learned to wear shoes, bathe, and not make messes in the house.

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

A little googling gave me this link which seems to fix it for other Win2003-users as well.

Edited by Helge

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

A little googling gave me this link which seems to fix it for other Win2003-users as well.

darn there you go googling and making me look silly :lmao:

OK so here is the answer

i went through your google solution and whilst it related to win98 i gave it a go, but as i suspected it did not resolve my issue.

But the word Google did. it made me think perhaps it wasnt an autoIT issue so i tried opening a differant chm file and the same symptoms occured.

so with a little google and a bit of trial and error.

regsvr32 hhctrl.ocx

regsvr32 itss

regsvr32 Urlmon.dll

regsvr32 Shdocvw.dll

regsvr32 Oleaut32.dll

regsvr32 Actxprxy.dll

regsvr32 Mshtml.dll

regsvr32 Shell32.dll

and a referance site http://forum.sysinternals.com/forum_posts....=1&get=last

Thanks for your help.

Edited by NTBM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0