Sign in to follow this  
Followers 0
yusuf

ControlID / ControlListView Problem

3 posts in this topic

#1 ·  Posted (edited)

Hi all, been using autoit for the last week and am still learning, have created a few scripts without any problem.

I want to make this script work with newsleecher (a usenet binary downloader), I haven't had a problem getting the controlID from all other programs but newsLeecher is a bit funny, as a test I just want to select (highlight) the items in the list before I progress and develop the script but ain't getting any luck, here's a sample

Opt("WinTitleMatchMode",2)
$t = "NewsLeecher"
$C = 67288
WinActivate($t)
ControlListView($t, "", $C, "SelectAll")

$C is the controlid (using the info tool), It activates my newsleecher window, but doesn't highlight the items in the list, I also tried substituting the control id for the classname e.g $C = "TVirtualExplorerTreeview1" but no luck, I know what you are thinking, it isn't a list but it is, Please if anyone here is using Newsleecher or could care to download and test it you'll know what I'm talking about.

Thanks in advanced and thanks for the great program, am learning something new everyday!

Here's some screens, the first one I put a red border to indicate the are / control I'm trying to control.

The second screen has the window info tool open, the thing is when I move the mouse around in that list (the red border) it changes alot, there are plenty of other controlid within the red border, its the ONLY program that does this, hope you can help, thanks.

Posted Image

Posted Image

The mouse cursor is within the red border and on the highlighted blue line 2 / 3 inches from the left, not captured cos of how screen shot works!

Edited by yusuf

Share this post


Link to post
Share on other sites



You seriously don't expect to get help spamming the board with the same post over and over do you?... I'll take 1 as speed issue, but you posted the same thing at least twice 7 minutes apart:

http://www.autoitscript.com/forum/index.ph...c=34280&hl=

http://www.autoitscript.com/forum/index.ph...c=34282&hl=

http://www.autoitscript.com/forum/index.ph...c=34283&hl=


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

You seriously don't expect to get help spamming the board with the same post over and over do you?... I'll take 1 as speed issue, but you posted the same thing at least twice 7 minutes apart:

http://www.autoitscript.com/forum/index.ph...c=34280&hl=

http://www.autoitscript.com/forum/index.ph...c=34282&hl=

http://www.autoitscript.com/forum/index.ph...c=34283&hl=

Sorry, I really didn't mean to post 3 times, Just wanted to make the subject clearer as I thought the first title wouldn't get any help.

Again, Sorry.

Can you help?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0