Sign in to follow this  
Followers 0
ByteRipper

Windows Post Installer

6 posts in this topic

#1 ·  Posted (edited)

hallo,

first of all excuse me for my english and especially for the propably messed up code. as a newbee with autoit thats the best i can do.

i startet to work with autoit a couple weeks ago.

when I wanted to put together a installations cd with nlite I bumped into windows post installer. now the last 14 days i tryed to do it with autoit. my result so far is in the attachement.

i do not get any further any more so properly somebody here from the forum can help me a little bit with it.

since there is no way to pass parameters with GUICtrlSetOnEvent i found a workaround here in the forum. so now i can pass parrameters.

besides other things unfortunately, i can not get my function _CheckDepExcProg to work.

$Depends should actually be 0, if there are no dependencies found. but it isn't. if i click for example on programm12 checkboxes are deaktivated without any dependencies.

i realy need help here from somebody that knows what he is doing. i just cant get any further.

PostInstaller.zip

Edited by ByteRipper

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

@ByteRipper, Welcome to the AutoIt Forums!

A few words of note:

- This is not a general support forum! For this reason, there is a v3 Support forum.

- This forum is for finished AutoIt scripts and scraps, not those that need to be debugged.

- Normally, when you request support for a nonfunctional script, you do not include a 1898 line script and expect anyone to take the time to wade through almost 2000 lines of code to determine what the issue is. If you need support, you will need to narrow down only the portion of your script that is not functioning, and create a new script that replicates the problem in the simplest and shortest way possible. We will then be happy to help you from that point.

EDIT: Clarity

Edited by this-is-me

Who else would I be?

Share this post


Link to post
Share on other sites

ok i try to do that and do a new post in v3 Support.

sorry for not doing it that way from beginning.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

The post has been moved by a moderator.

EDIT: I still recommend you narrow down that large script to the problematic area.

Edited by this-is-me

Who else would I be?

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

ok i got the function working now.

now here comes a new question. if i have more than one entry in Depends and Excludes seperated by || how can i check them all one by one in that function _CheckDepExcProg?

i know i can use StringSplit, but i have no idea on how to put it all together in that function to get it to work.

your help is realy appreciated.

Edited by ByteRipper

Share this post


Link to post
Share on other sites

anyone here that can help me with that?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0