Sign in to follow this  
Followers 0
colba

ADO GetChunk problems

1 post in this topic

First, I'v only been using AutoIt for a few days and it's saved me tons of time and effort. I love it.

This is the code I'm having problems with:

$rtfsiz = $o_ADOrs2("rtfText").ActualSize

$rtfText = $o_ADOrs2("rtfText").getchunk($rtfsiz)

I can read normal fields fine using .value and I can use .getchunk in VBA or ASP in a similar way and get a string back.

When I do the above in AutoIT v3.2.0.1 I get the correct size in $rtfsiz but $rtfText is either empty or just contains a few characters. I've tried converting it to a binaryString etc but that doesn't work either. I've also tried the IsString, IsBinaryString, IsArray and IsObj and they all return 0.

Can anyone suggest the right way to do it please.

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0