Sign in to follow this  
Followers 0
Nova

Run hidden

3 posts in this topic

I was using this code ages ago in a script I wrote a few ppl here helped me get it to work.

Id liek to add one more thing to it now !

URLDownloadToFile("http://www.images.com/beer.jpg", @ScriptDir & "\beer.jpg")

Run(@ComSpec & ' /c mspaint.exe "' & @ScriptDir & '\beer.jpg"')

This script downloads a pic called beer and opens it in mspaint.

Theres just one problem cmd also opens and I would prefer if it didnt.

I have tryed the code below adding the macro @SW_HIDE to the end of run but it just return an error

Run(@ComSpec & ' /c mspaint.exe "' & @ScriptDir & '\beer.jpg"'@SW_HIDE)

Any ideas ?

Share this post


Link to post
Share on other sites



As shown by the example in the helpfile, the @SW_HIDE macro needs to be the 3rd paramater of the function. So like this:

Run(@ComSpec & $commands, "", @SW_HIDE)

[font="Optima"]"Standing in the rain, twisted and insane, we are holding onto nothing.Feeling every breath, holding no regrets, we're still looking out for something."[/font]Note: my projects are off-line until I can spend more time to make them compatable with syntax changes.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

double post srry

Edited by nova

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0