Sign in to follow this  
Followers 0
Guest richardm

Virus in installer for AutoIT3 ?

5 posts in this topic

Hi -

I just attempted to install AutoIT v.3.2.0.1. The .exe ran and my AVG virus scanner immediately reported a Trojan Horse PSW.Lineage.PQ in InstallOptions.dll. This may be a false positive, but I thought you'd like to know about it just in case!

Share this post


Link to post
Share on other sites



Hi -

I just attempted to install AutoIT v.3.2.0.1. The .exe ran and my AVG virus scanner immediately reported a Trojan Horse PSW.Lineage.PQ in InstallOptions.dll. This may be a false positive, but I thought you'd like to know about it just in case!

Did you read the sticky on top of this forum?

Share this post


Link to post
Share on other sites

More InstallOptions.dll is not part of AutoIT setup so why to post here?

Share this post


Link to post
Share on other sites

Did you read the sticky on top of this forum?

Nope. I drilled down to the forum I originally misposted in straight from the autoitscript.com homepage. Never even saw the other forums. Sorry if it's a question that gets repeatedly asked, I know that gets annoying.

More InstallOptions.dll is not part of AutoIT setup so why to post here?

Really? When running autoit-v3.2.0.1-setup.exe, files are extracted to a temporary folder in C:\Documents and Settings\<username>\Local Settings\Temp\ , presumably as support for the installation program. One of those files is apparently InstallOptions.dll which is what triggered the warning. If InstallOptions.dll is really not extracted from the AutoIT setup.exe then presumably I have a different problem.

More simply, I was installing AutoIT and during that process my virus scanner flagged InstallOptions.dll as being infected. Why would I not post about it here? I actually thought I was being helpful.

Share this post


Link to post
Share on other sites

More simply, I was installing AutoIT and during that process my virus scanner flagged InstallOptions.dll as being infected. Why would I not post about it here? I actually thought I was being helpful.

The DLL you refer to is part of the NSIS installer so the false positive will occur on any installer build with NSIS.

There is no need to feel offended... you need to realise that many people make these type of post in the AutoIt forum and even accuse us of spreading viruses in a less then polite way ...

;)


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0