Jump to content
Sign in to follow this  
kjactive

New tool - a PreProcessor

Recommended Posts

Hallo AMD

I've made an opdate to 3.2.0.9 that suite your concern about automatically updates...

Wooltown - thanks for your bug report - I found the trouble and some other more visual but anyway gone...

1.Bug fix - Typo that au3check didn't catch ++

2.Bug fix - GUICtrlSetOnEvent in the include subfunctions used scan failure, if the function argument was enpty, this displayed an empty node in the function listview column - Wooltown

3.Bug fix - Visual error that displayed non buildin functions even though these was catched by the error handle process and not included...

4.Updated the auto update system as to now actual doing an async update process, without any interfear by the users - I hope this is actually working on all computers as if not end users up with a messy program and if this is the case please do a compleat update from link below and make a report ( It's working without complains in my test inveriment ) - AMD...

Download link:

http://www.sitecenter.dk/latenight/nss-fol...t%20Manager.zip

kjactive :whistle:

Edited by kjactive

Share this post


Link to post
Share on other sites

Hello !

I still get the message "ERROR - Function Buildin failures, Read Log script", but it seems like the PreProcessed script works, but where is the logfile located ?

Share this post


Link to post
Share on other sites

Hallo Wooltown

yes it seems to me that there is a lot of _read functions missing in the scripts for some reason - didn't you let out an include script with all these functions in the scripts you mailed to me, the functions is just not present to be buildin but I must admit that your project is to heavy to look deep into almost 2MB

These functions are missing: - the failure reports that these functions are not present functions to be buildin....

_ReadCurrentWeek _ReadServiceMode _ReadStaffActivityToArray _ReadServiceMode _ReadResourceOutputToArray _ReadServiceMode _ReadTestAreaToArray _ReadServiceMode _ReadTestAreaGroupToArray _ReadServiceMode _ReadTestTypeToArray _ReadTestersToArray _ReadTestersToArray _ReadTestersToArray _ReadTestersToArray _ReadTestersToArray _ReadTestersToArray _ReadServiceMode _ReadTestAreaToArray _ReadServiceMode _ReadServiceMode _ReadStaffActivityToArray _ReadServiceMode _ReadStaffActivityToArray _ReadServiceMode _ReadResourceOutputToArray _ReadServiceMode _ReadResourceOutputToArray _ReadServiceMode _ReadTestAreaToArray _ReadServiceMode _ReadTestAreaGroupToArray _ReadServiceMode _ReadTestTypeToArray _ReadCurrentWeek _ReadServiceMode _ReadStaffActivityToArray _ReadServiceMode _ReadResourceOutputToArray _ReadServiceMode _ReadTestAreaToArray _ReadServiceMode _ReadTestAreaGroupToArray _ReadServiceMode _ReadTestTypeToArray _ReadTestersToArray _ReadTestersToArray _ReadTestersToArray _ReadTestersToArray _ReadTestersToArray _ReadTestersToArray _ReadServiceMode _ReadTestAreaToArray _ReadServiceMode _ReadServiceMode _ReadStaffActivityToArray _ReadServiceMode _ReadStaffActivityToArray _ReadServiceMode _ReadResourceOutputToArray _ReadServiceMode _ReadResourceOutputToArray _ReadServiceMode _ReadTestAreaToArray _ReadServiceMode _ReadTestAreaGroupToArray _ReadServiceMode _ReadTestTypeToArray

I tryed to trach down one function but failed, You got to help me on this one...

Kjactive :whistle:

Edited by kjactive

Share this post


Link to post
Share on other sites

Hallo Wooltown

Ohh yes I can see that - and I must admit that I didn't understanded why the application didn't returned an error when run, these functions are native included and that's why they was not present in the list - I have to look into this error handle function ones more, Thanks for your report - I'll get back, one nice part is that this makes me do a dubble test on the auto update system - Høø ( danish for a small laught )

I must admit that dispite the easy debug process, the number of errors increases with the complexity of the program

kjactive :whistle:

Share this post


Link to post
Share on other sites

When I try to run the latest release it insist on administrator rights? Anyone else experiencing this, or is it my system? Maybe a feature? Runing the ME version does not behave like this.

Share this post


Link to post
Share on other sites

Hallo Uten

Yes the standard Project Manager has #requireadmin included to serve administrator rights related to Vista and WinXP ( this is a Uni compile wrap too ) while the Project ManagerME is an ansi compile wrap without #requireadmin function included to serve Win98/ME/2K users...

I don't know if this could be a problem to some users but should be correct related to Microsoft security policy

The autoit3 topics has a very informative page on the subject - Autoit on windows vista

If this continue to make trouble I could remove the function but please read out the previous page in the topics, personal I think that MS has a overprotected policy but this is how they think...

kjactive :whistle:

Edited by kjactive

Share this post


Link to post
Share on other sites

Hallo Wooltown

You nailed me ones more ;) - True the error handle function didn't looked in the mainscript function list but reported errors if functions was not located in the external function list, the Project Manager did not produced a faulty script but informations - fixed...

Could any of you devoded debuggers please check the auto update system attached in rev. 3.2.0.9, should make notification first thing tomorrow, please report if this ends with a failure and a ruined application - sorry but async. processes is a hard one to control but very nice if it works ( it does on my two different computers ) :whistle: ...

If failure here is the link to a fresh install: Sorry!

http://www.sitecenter.dk/latenight/nss-fol...t%20Manager.zip

Uten - Please I would like to hear a comment on your subject and owercome with admintration rights...

Thanks and keep up bug reports and do comments...

kjactive :lmao:

Edited by kjactive

Share this post


Link to post
Share on other sites

Auto update ???? - I don't know didn't get any notification.

Found another obscure error, The "remove Tab chars" check box was empty, checked it and clicked The Process button to choose a script, when I pressed Open, and returned to the Process manager, the checkbox was removed. The only way to have the check box activated is to check it and restart Process Manager, but even then when the process is finished, the check box is removed and the tab characters is still there.

May I suggest a new function: "Remove leading blank and tab characters".

Share this post


Link to post
Share on other sites

Hallo Wooltown

Is auto update turned on in the preferences - else do a manual activate from the about window...

The "remove Tab chars" check box was empty

Can I understand this as - The control is without attached text, if this is the case that's because you have a wrong language script going around and if this is not the case please do a update ones more as I just did a test and there is absolute nothing wrong here - even the auto update system did well, sorry for your inconvenient trouble but afterall it's your TTM 2MB application that's putting PM to its absolute limit with lots of special options used - thanks...

Remark on language script: this is one of the real savers to applications, both to load and execute time, as identically text lines do only has to be read ones and can easy be exchanged with other languages without interfear with programming. Project Manager itself has about 2000 lines of text that gets down to an array of 241 string nodes...

Remove leading blank and tab characters

I'll think about it ( leading / trailing blanks )...

Download link:

http://www.sitecenter.dk/latenight/nss-fol...t%20Manager.zip

kjactive :whistle:

Share this post


Link to post
Share on other sites

Autoupdate work for me, execpt...one more step needed. After the end, it needs to restart the app, other than that, Thanks...Will make it just that much easier to use.

Share this post


Link to post
Share on other sites

Hallo AMD and Wooltown

That's nice that the auto update was alright, It do make life a bit easier - actually I made another 'Rainy day'&%&¤ update ( it rained the whole day ) - Wooltown you got your new option, to strip leading and trail spaces from the preprocessed script...

1.Attached a new preprocess option - strip leading and trail spaces ( tab characters as well ) on every line in the preprocessed script - wooltown

2.Changed some of the preprocess functions to run a little faster...

3.Moved the remove function of the temporary Update script from the exit to just after the intuition has finished to open...

4.Changed the auto update script to make a copy of the original files and try to reinstall if the update returned a failure...

5.Updated the topics - VITAL NOTE macro scripts that uses the PreProcessOpt command has to be updated as there is now one entry more than previous...

About open Project Manager again after an auto update process - I don't know how as this is ment and probably started as a SciTe macro tool and as that has to be started from SciTe to be functional...

kjactive :whistle:

Edited by kjactive

Share this post


Link to post
Share on other sites

You would just need to add a run command to the end of the successful update. You probably would want to check which app the user is using xp/me before killing the window, that way you would know which one to restart...

Something like this before killing the "Project Manager" window:

$processME = False
If ProcessExists("Project ManagerME.exe) Then $processME = True

Then after a sucessfull update:

IF $processME Then
    Run(@ScriptDir & "\Project ManagerME.exe,@ScriptDir)
Else
    Run(@ScriptDir & "\Project Manager.exe,@ScriptDir)

Endif

Share this post


Link to post
Share on other sites

Hallo AMD

I attached a ReExecute process after Project Manager auto update has finished, I'm not positive that this is actually right as PM is ment as a SciTE macro tool - please check it out tomorrow

Some miner visual bugs fixed too ( still raining %¤&(/&¤ )

kjactive :whistle:

Edited by kjactive

Share this post


Link to post
Share on other sites

Just some FYI:

1. About those two functions that I would not reconize, on one func, somehow the ending "Endfunc' line had a leading space on it and apparently autoit doesn't care about it but your app needs to have everything in the correct locations ( you must just check the begining of the line, instead of just checking to see if the line contains a perticular string, probably for speed reasons), the other function was basically one big local to path include line and the include file name looked like Include "xxxxx(...).au3". For some reason, you app didn't like the "()" chars. After fixing the above probems, it did work correctly again w/o adding the functions to be included.

2. I would say that there still might be a autoupdate issue, but I just did a fresh install of the current one so I'll let you know on the next update if it is still not working correctly.

3. I'm also havin a prob with a macro that I wrote to do all the needed steps that are needed so that I can just compile my one of my current projects. When I would run it, the pro mgn window would disapear form the taskbar and I could see it still running in the backround and the only way to get it back was to kill task and restart it...Maybe its just an incorrectly written macro. I did try to follow the others...

Edit: I just was looking in the help fle and seen that there IS a macro writer, and will play with that, although I did just notice that mine has NO icon on the top buttons so it not too easy to figure out which button is which...

Share this post


Link to post
Share on other sites

Hallo AMD

one func, somehow the ending "Endfunc' line had a leading space

Yes I see your point - I include some sort of a strip function or something like that, But It's just not posible to cope on every typos that can be done in a typeless language like autoit3 with that many options...

big local to path include line

Could you provide me with the exact line ?

the pro mgn window would disapear form the taskbar and I could see it still running in the backround

pro mgn = Project manager - right? well there is some known bugs:

1.There is some visual trouble with the macro language as if a intuition window has been opened from the editer the listviews will not update before i quit the editer and do a new PreProcess - I don't know if this is autoit3 bug or something in the Project manager but the preprocess works allright...

2.The macro editer will not set in the last three lines and do not update correctly - I'm positive that's a autoit3 bug related to the edit control...

that there IS a macro writer

Yes attached first time in rev. 3.2.1.2, it was just a fast test wrap but now very functional and I'm working on a update - but I discovered on my computer at work, that there was some trouble with the auto update script as this didn't installed the graphics needed, ending up with a application with a lot of controlls without the graphics - I'll do a fix soon...

Actually I'm almost finished with an update - in a day or two...

Thanks for the bug reports - wooltown too that dropped me a mail on a subject I'll have to fix too...

Perosnal I use the Project Manager a lot and try to keep the software as bug-free as posible, I must admit that the number of

errors increases with the complexity of the program but I do love to impliment this automate macro system, still it would be a lot easier if I had planed this from start - just a warning to other programmers that want to write macro systems into the applications...

kjactive :whistle:

Edited by kjactive

Share this post


Link to post
Share on other sites

New update to rev. 3.2.1.4

1.Attached a macro script editer to simplify load, edit and test - all commands available from toolbar with tooltip syntax Ctrl+Shift+M

2.Changed Filecopy and filedelete macro command as to copy or remove directories if the from argument is only a path...

3.Add a security msgbox to macro command filedelete directory remove - this is to dangeres without...

4.Attached a new macro command - PreferencesOpt - Change Project Manager default settings...

5.Changed the auto update script as to do most work from the script and less internal...

6.Extended the errorhandle to cope with function typos - AMD

7.Bug fix - if #includes was in a compleatly different path than the original - the function search failed - fixed

8.bug fix - Macro commands filecopy / filemove had wrong default values - fixed

9.all intuitions has F1 help attached - included the new Macro editor as to lookup the commands site directly...

( needs hh.exe viewer from 'MS HTML Help Workshop' - free editor / compile system )

Auto update or download from site:

http://www.sitecenter.dk/latenight/nss-fol...t%20Manager.zip

I go on a three week holiday by the sea - see you later...

kjactive :whistle:

Edited by kjactive

Share this post


Link to post
Share on other sites

Anouther Fu¤#&'ing rain update

What do asia peoble do in the rain season, stucked with the computer to do update 3.2.1.5

1.Bug fix - the function editor included some temporary files into the list - fixed...

2.Changed the preferences default settings to be used if makefile was not present to a new process...

3.Removed menu option - write Log to SciTE, was not working...

4.Attached preferences with load / Save default setting controls - and an option to do dynamic preferences auto save at exit...

5.Attached one option to the Macro command PreferencesOpt - a backup file / path variable, where to backup as or to...

6.Vital: Changed macro commands PreProcessOpt/ PreferencesOpt/ResourceOpt argument keyword from space to | as to make some syntax standard here...

7.Vital: Changed the auto buildin icons from directory not to overwrite autoit3 buildin default icons - previous PM exchanged one ( please add one to the order in scripts )

8.Bug fix - When language translation keyword was not present, the listviews was not cleared - fixed...

9.Attached Au3Check process last in the preprocess - display result in the process tooltip or read the total return from a menu...

10.Removed the 'Compile editor' menu from the edit menu as this was dubble confect - use project menu execute 'Compile with options' ( ctrl+shift+O )

11.Found an Obfuscator commandline bug - Obfuscator do not take the /Beta argument - obfuscator now always use the public version...

12.Add security error handle process to all controls in the 'compile with options' intuition to block not wanted controls...

Download from site:

http://www.sitecenter.dk/latenight/nss-fol...t%20Manager.zip

Or wait for autoupdate...

Kjactive :whistle:

Edited by kjactive

Share this post


Link to post
Share on other sites

Another rainy day update rev. 3.2.1.6

1.Changed the compile compression with two new options 'High & Ultra' and optimized rate with 5 to 12%, default is now aut2exe maximum, high is the Project Manager optimized internal process, Ultra - never use it - very slow but extend rate with 2%...

2.Changed 'allow decompress' to acually work - if no phrase included 12345 is used...

3.Attached an option to the Macro editer - load / save last macro script from accelerator Ctrl+Shift+V / +S

4.Bug fix - Macro command 'RelativePath' did oppesit than wrote in topics - removed the backslash as it should attach one if not present - fixed...

5.Vital Bug fix - Just discovered that autoit3 install process changed settings in windows ini base like durring a beta install, that ruined the internal compile system - fixed...

6.Attached a new powerfull option - to run macro scripts direktly from SciTe commandline arguments ( keyword /m - lookup 'special notes' in topics ) , macros is run after a preprocess has finished - option to make different setups, lookup 'special notes' in the topics....

7.Extended the function scan and buildin process to include functions used from ' AdlibEnable( and Call( ' - NOTE - this function can't handle calls as variables...

8.Bug fix - Special buildin functions like from AdlibEnable( ec. was buildin even commented out - fixed

9.Included a Macro script in the zip to do a directly 'preprocess, compile and test the execute' to be called from SciTe macro system - lookup 'Special notes' in topics

10.Changed the au3check process on preprocess scripts to be more directly as to display error / warnings in the infoline

11.New powerfull option attached - to include a Tools menu, insert external execute tools like calculator, hexediters or what else a dos can do, to run async, inserted from a simple script 'Tools.txt' in the data directory - example attached the zip archive, lookup 'tools menu' in topics...

Download from site:

http://www.sitecenter.dk/latenight/nss-fol...t%20Manager.zip

Or let the auto update process do the trick...

kjactive :)

Edited by kjactive

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...