Sign in to follow this  
Followers 0
jacQues

ClipGet() / ClipPut() limitations?

4 posts in this topic

#1 ·  Posted (edited)

One of my scripts uses ClipGet() a lot, about five times per second. It uses Send("^c") first then ClipGet() to read a value. After a few days ClipGet() always returns the same value (which is some previous value). The script also uses ClipPut() and then Send("^v{ENTER}") to reply. This also seems to fail when the problem occurs. E.G. the ^v pastes the same ClipGet() value.

The problem may be a Windows XP problem, not sure. But I couldn't find anything in the MS knowledgebase. AutoIt 3.2.0.1 was used. Reproducing the bug is difficult at best.

CODE
; Get a line of text...

MouseClick($button,$x,$y,1,1)

Send("^c")

; ClipGet() is processed, usually nothing happens, sometimes the script relies.

; Reply, $line contains the reply which only contains ASCII 32..254...

ClipPut($line)

MouseClick($button,$x,$y,1,1)

if ClipGet()<>$line then

; How is this possible? Stil it _does_ happen!!

GiveWarning()

endif

Send("{ENTER}^v{ENTER}")

jacQues Edited by jacQues

Share this post


Link to post
Share on other sites



One of my scripts uses ClipGet() a lot, about five times per second. It uses Send("^c") first then ClipGet() to read a value. After a few days ClipGet() always returns the same value (which is some previous value). The script also uses ClipPut() and then Send("^v{ENTER}") to reply. This also seems to fail when the problem occurs. E.G. the ^v pastes the same ClipGet() value.

The problem may be a Windows XP problem, not sure. But I couldn't find anything in the MS knowledgebase. AutoIt 3.2.0.1 was used. Reproducing the bug is difficult at best.

CODE
; Get a line of text...

MouseClick($button,$x,$y,1,1)

Send("^c")

; ClipGet() is processed, usually nothing happens, sometimes the script relies.

; Reply, $line contains the reply which only contains ASCII 32..254...

ClipPut($line)

MouseClick($button,$x,$y,1,1)

if ClipGet()<>$line then

; How is this possible? Stil it _does_ happen!!

GiveWarning()

endif

Send("{ENTER}^v{ENTER}")

jacQues
You just forget to mention the application which is receiving the MouseClick.

More clicking on what is really something selected before the clicking.

At least post an image on where the Clicking goes.

I have no cristall ball. Bug report should be better documented as stated in the above sticky.

:P

Share this post


Link to post
Share on other sites

You just forget to mention the application which is receiving the MouseClick.

More clicking on what is really something selected before the clicking.

At least post an image on where the Clicking goes.

I'm not sure if its a Windows bug or an AutoIt bug.

Anyhow, the application is Magic Online. (see www.wizards.com/magiconline)

The clicks are on chatlines and select that line, then use ^c to "get" the chatline.

Sometimes the click "misses" but then ClipGet() is simply empty ("") after the ^c.

Could it be a Magic Online bug at all?

jacQues

Share this post


Link to post
Share on other sites

I'm not sure if its a Windows bug or an AutoIt bug.

Anyhow, the application is Magic Online. (see www.wizards.com/magiconline)

The clicks are on chatlines and select that line, then use ^c to "get" the chatline.

Sometimes the click "misses" but then ClipGet() is simply empty ("") after the ^c.

Could it be a Magic Online bug at all?

jacQues

Thanks. I have no intention to chat on this site. I hope somebody can help you.

I move the pot to support forum so you can have some help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0