Sign in to follow this  
Followers 0
danpaul23

radio select question

6 posts in this topic

I'm getting frustrated because I know this should be easy. I've been trying to figure it out for awhile. I just want to select a particular radio button.

I'm getting the following error:

--> IE.au3 Warning from function _IEFormElementRadioSelect, $_IEStatus_NoMatch

CODE
#include <IE.au3>

$sURL = "http://www.amazon.com/b/ref=sv_b_0/102-5993488-0177751?ie=UTF8&node=241582011"

$oIE = _IECreate($sURL)

$oForm = _IEFormGetCollection($oIE, 3)

_IEFormElementRadioSelect ($oForm, "Start(s) of Title Word(s)" , "select-title")

Share this post


Link to post
Share on other sites



The problem is that you are using the exact text of the radio button and not its value. Using IE builder ( I think I mentioned that its useful before) I can see the value is field-title-words-begin . That makes your code...

#include <IE.au3>

$sURL = "http://www.amazon.com/b/ref=sv_b_0/102-5993488-0177751?ie=UTF8&node=241582011"
$oIE = _IECreate($sURL)
$oForm = _IEFormGetCollection($oIE, 3)
_IEFormElementRadioSelect ($oForm, "field-title-words-begin" , "select-title")

I know what its like to bang your head against a seemingly simple IE.au3 thing... don't worry you'll get it.


While ProcessExists('Andrews bad day.exe')
	BlockInput(1)
	SoundPlay('Music.wav')
	SoundSetWaveVolume('Louder')
WEnd

Share this post


Link to post
Share on other sites

The problem is that you are using the exact text of the radio button and not its value. Using IE builder ( I think I mentioned that its useful before) I can see the value is field-title-words-begin . That makes your code...

#include <IE.au3>

$sURL = "http://www.amazon.com/b/ref=sv_b_0/102-5993488-0177751?ie=UTF8&node=241582011"
$oIE = _IECreate($sURL)
$oForm = _IEFormGetCollection($oIE, 3)
_IEFormElementRadioSelect ($oForm, "field-title-words-begin" , "select-title")

I know what its like to bang your head against a seemingly simple IE.au3 thing... don't worry you'll get it.

Thanks for your help and encouragement. I'm still getting the same error message when I try to run the revised script. Also, I've wanted to use the the IE builder program but I'm not sure how to install it. I'm unable to open the file after I download it. The .rar extension is not recognized.

Share this post


Link to post
Share on other sites

Hmm are you using an older version of autoit? I'm using the newest and have tested that script as working... I think Dale released a new version of IE.au3 with the new release so if your running an older version with the older IE.au3 that could do it. Also .rar formats are opened by a program called winrar. Do a google and you'll find it easy. Its like winzip; all .rar files are compressed. Once you unrar the file you are left a folder with an au3 script called IE builder, just run it.

If you are using the newest version can you post the entire scite output?

Thanks


While ProcessExists('Andrews bad day.exe')
	BlockInput(1)
	SoundPlay('Music.wav')
	SoundSetWaveVolume('Louder')
WEnd

Share this post


Link to post
Share on other sites

Hmm are you using an older version of autoit? I'm using the newest and have tested that script as working... I think Dale released a new version of IE.au3 with the new release so if your running an older version with the older IE.au3 that could do it. Also .rar formats are opened by a program called winrar. Do a google and you'll find it easy. Its like winzip; all .rar files are compressed. Once you unrar the file you are left a folder with an au3 script called IE builder, just run it.

If you are using the newest version can you post the entire scite output?

Thanks

Okay, I don't have the winrar program so that must be the problem. Thanks for the clarification. I'm excited to try it out when I get a minute.

Share this post


Link to post
Share on other sites

Okay, I don't have the winrar program so that must be the problem. Thanks for the clarification. I'm excited to try it out when I get a minute.

I got the ie builder program downloaded and it looks like it will be useful but it's not clearing up my confusion about my original problem. I've tried the suggested script and every other option and permutation I can think of but can't figure out what the heck I'm doing wrong. It seems so simple but I'm not making any progress.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0