Sign in to follow this  
Followers 0
analogkid

AU3_PixelChecksum() starts returning 0x80000000?!

2 posts in this topic

#1 ·  Posted (edited)

Hello all, long time listener, first time poster, etc ... :">

Hopefully someone one here knows what's up with AU3_PixelChecksum in 3.1.1.0 and 3.2.0.1.

Here's the issue: I'm simply trying to capture the state of a object by scanning a portion of the screen -- pretty simple task. The block is (7,7,17,27) and it does occasionally return something nice and useful like 0x4a608d8d, but it seems that it occasionally will start returning 0x80000000, and then continue to only return that value for any block in roughly the same part of the screen.

I've tried skipping more/fewer pixels without any change. I even tried doing the following to 'shake' it up and maybe have it work again:

long pixelChecksum = AU3_PixelChecksum(7,7,17,27, 2);  // mysteriously returns 0x80000000
pixelChecksum = AU3_PixelChecksum(0,0,1,1, 1);   // returns 0x4dbe0bf5
pixelChecksum = AU3_PixelChecksum(7,7,17,27, 2);  // *still* returns 0x80000000

I don't get it ... 0x80000000 is clearly not a valid checksum. Has anyone else had any issues like this?

I'm running Windows XP Pro (SP2 + a gajillion hotfixes), MSVC++ 2003, P4 3.2GHz, 1GB RAM, single Dell 2005FPW (wide) @ 1680x1050 32bit, AutoITx 3.2.0.1 (AutoItX3.dll v3.2.0.1, AutoITx3.lib both dated 8/13/2006).

Help please! :)

Edited by analogkid

Share this post


Link to post
Share on other sites



Getting the same thing, PixelChecksum seems to be bugged in AutoItX :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0