Sign in to follow this  
Followers 0
PerryRaptor

ArraySearch Help

3 posts in this topic

Need some help and ideas...I cannot get the expression below to match the logged in UserName with that in a ini file.

$UserNameSearch = StringSplit(IniReadSection($UserName, "SArights" )," ", 1, 1)
If $AuthUser == _ArraySearch($UserNameSearch,  $AuthUser) Then ...

::: .ini file :::

[sArights]

Bob

Joe

Danny

Fred

Lucy

Share this post


Link to post
Share on other sites



Need some help and ideas...I cannot get the expression below to match the logged in UserName with that in a ini file.

$UserNameSearch = StringSplit(IniReadSection($UserName, "SArights" )," ", 1, 1)
If $AuthUser == _ArraySearch($UserNameSearch,  $AuthUser) Then ...

::: .ini file :::

[sArights]

Bob

Joe

Danny

Fred

Lucy

Probably because you are trying to StringSplit() IniReadSection() as if it returns a string... you're not even using IniReadSection() correctly (the parameters).

Might want to look at IniReadSection() in the help file.


[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

I figured it out...I was thinking _ArraySearch() returned the matching string, but it returns the cell number that contains the string.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0