Sign in to follow this  
Followers 0
dinodod

Child GUI not apearing all the time

6 posts in this topic

#1 ·  Posted (edited)

Ok, now I need to understand this. I asked several people for some advise on this topic and it appears that this is more than just an incident with my coding. I now am asking for support to see whay GUI controls seem to flake out at random.

controls not appearing when they should

controls stuck behind other controls instead of being in front even when popupwindow is an option.

other random issues

I am using the release version of autoit 3 (3.2, I believe)

Is there any way to trace the issue? and yes, I am on XP SP2.

Thanks

Edited by dinodod

Digital Chaos - Life as we know it today.I'm a Think Tank. Problem is, my tank is empty.The Quieter you are, the more you can HearWhich would you choose - Peace without Freedom or Freedom without Peace?Digital Chaos Macgyver ToolkitCompletely Dynamic MenuSQLIte controlsAD FunctionsEXCEL UDFPC / Software Inventory UDFPC / Software Inventory 2GaFrost's Admin Toolkit - My main competitor :)Virtual SystemsVMWAREMicrosoft Virtual PC 2007

Share this post


Link to post
Share on other sites



Ok, now I need to understand this. I asked several people for some advise on this topic and it appears that this is more than just an incident with my coding. I now am asking for support to see whay GUI controls seem to flake out at random.

controls not appearing when they should

controls stuck behind other controls instead of being in front even when popupwindow is an option.

other random issues

I am using the release version of autoit 3 (3.2, I believe)

Is there any way to trace the issue? and yes, I am on XP SP2.

Thanks

You may be right, it may be the fault of SP2. you can try testing your script with an older autoit version (or beta), or simply use your script with XP SP1!! i was testing some scripts with older versions like 98/ME and the effect is always different from running them with XP.

Share this post


Link to post
Share on other sites

Ok, now I need to understand this. I asked several people for some advise on this topic and it appears that this is more than just an incident with my coding. I now am asking for support to see whay GUI controls seem to flake out at random.

controls not appearing when they should

controls stuck behind other controls instead of being in front even when popupwindow is an option.

other random issues

I am using the release version of autoit 3 (3.2, I believe)

Is there any way to trace the issue? and yes, I am on XP SP2.

Thanks

This all sounds like a control sizing issue.

[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

This all sounds like a control sizing issue.

Can you provide an example of your code so I can compare against mine.

Sample:

$MainGUI = GUICreate("Title", $MainGUI_Width, $MainGUI_Height) ; will create a dialog box that when displayed is centered

$ChildGUI_TreeView = GUICreate("TreeView", 220, 320, 20, 20, $WS_CHILD, $WS_EX_CLIENTEDGE, $MainGUI)


Digital Chaos - Life as we know it today.I'm a Think Tank. Problem is, my tank is empty.The Quieter you are, the more you can HearWhich would you choose - Peace without Freedom or Freedom without Peace?Digital Chaos Macgyver ToolkitCompletely Dynamic MenuSQLIte controlsAD FunctionsEXCEL UDFPC / Software Inventory UDFPC / Software Inventory 2GaFrost's Admin Toolkit - My main competitor :)Virtual SystemsVMWAREMicrosoft Virtual PC 2007

Share this post


Link to post
Share on other sites

Can you provide an example of your code so I can compare against mine.

Sample:

$MainGUI = GUICreate("Title", $MainGUI_Width, $MainGUI_Height) ; will create a dialog box that when displayed is centered

$ChildGUI_TreeView = GUICreate("TreeView", 220, 320, 20, 20, $WS_CHILD, $WS_EX_CLIENTEDGE, $MainGUI)

What about you post the code that is given problems ?

:)


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Well, I guess I had more time than brains cause I went back and ripped apart my applet and turned just about everything into either a SELECT CASE or a FUNCTION.

My guess was that I was somehow loading too many guis and it started to corrupt my GUI somehow. Since I've forced everything to be in functions, I have much more control over what gets loaded and when. All I know is that I had to make a trade off. A working GUI but I have to declare a lot of GLOBAL variables :)

It seems to have stabalized now. I'll keep you posted.


Digital Chaos - Life as we know it today.I'm a Think Tank. Problem is, my tank is empty.The Quieter you are, the more you can HearWhich would you choose - Peace without Freedom or Freedom without Peace?Digital Chaos Macgyver ToolkitCompletely Dynamic MenuSQLIte controlsAD FunctionsEXCEL UDFPC / Software Inventory UDFPC / Software Inventory 2GaFrost's Admin Toolkit - My main competitor :)Virtual SystemsVMWAREMicrosoft Virtual PC 2007

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0