Sign in to follow this  
Followers 0
b0x

Auto3Lib Error

16 posts in this topic

I get an errormessage if i use the ScreenCap Function in Auto3Lib. Maybe someone else has an error like this too.

_API_GetCursorInfo: 998, Invalid access to memory location..

greez b0x

Share this post


Link to post
Share on other sites



I get an errormessage if i use the ScreenCap Function in Auto3Lib. Maybe someone else has an error like this too.

_API_GetCursorInfo: 998, Invalid access to memory location..

greez b0x

maybe you can post the code that causes the error, otherwise we'll have to guess....


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

In my script i only have the line

#include <A3LScreenCap.au3>
_ScreenCap_Capture("Q:\project b0x\"&$scrn, 328, 325, 343, 482)

maybe the fault is in the Auto3Lib, i tried to look up but i failed, Iam not good in such things.

here's the link to the thread where i got the library, maybe one of you can try ScreenCap if it works at yours.

Share this post


Link to post
Share on other sites

#include <A3LScreenCap.au3>

_ScreenCap_Capture("Q:\project b0x\"&$scrn, 328, 325, 343, 482)

a two line code???

it can't work without the variable "$scrn" given a value...

AFAIK

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Of course i have more code, and the variable is already declared, but only these 2 lines are my part to the screencap the rest is unchanged in the library :)

Share this post


Link to post
Share on other sites

In my script i only have the line

#include <A3LScreenCap.au3>
_ScreenCap_Capture("Q:\project b0x\"&$scrn, 328, 325, 343, 482)

maybe the fault is in the Auto3Lib, i tried to look up but i failed, Iam not good in such things.

here's the link to the thread where i got the library, maybe one of you can try ScreenCap if it works at yours.

that cannot be the whole script, because you are using an undefined variable ($scrn) and the interpreter would have caused a runtime error (Error: variable used without beeing declared). Besides that, the screen capture function works on my system (WinXP SP2).

Cheers

Kurt


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

I get an errormessage if i use the ScreenCap Function in Auto3Lib. Maybe someone else has an error like this too.

_API_GetCursorInfo: 998, Invalid access to memory location..

greez b0x

As I explained in the PM you sent me an hour ago, I don't think the problem is with the UDF. _API_GetCursorInfo is called inside of _ScreenCap_Capture to get the global cursor information. It is allocating a very small amount of memory. It appears that your machine is low on memory. The screen image is capture to memory before writing to a file. It takes about 4-5 MB of memory to do this.

Auto3Lib: A library of over 1200 functions for AutoIt

Share this post


Link to post
Share on other sites

hmmm ive 1GB memory and i just reinstalled windows. That cannot be!

Share this post


Link to post
Share on other sites

hmmm ive 1GB memory and i just reinstalled windows. That cannot be!

something completely different. You are not running this on 64-Bit Windows XP, do you?


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

no i dont!

//EDIT

is it possible to save the screenshots as a jpeg? or only bmp?

Edited by b0x

Share this post


Link to post
Share on other sites

no i dont!

//EDIT

is it possible to save the screenshots as a jpeg? or only bmp?

O.K. and you get the same error if you run ONLY the two line script you posted?


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

yes i ve already tested this, and iam gettin the error at the examplescript too. :/

Share this post


Link to post
Share on other sites

yes i ve already tested this, and iam gettin the error at the examplescript too. :/

well, then it's a problem with your system....


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

okay thank you anyways :)

Share this post


Link to post
Share on other sites

ok i tried it on my other 2 PCs too and it doenst work, i tried it on Pcs of friends and family members and theyre gettin' another error, i though w00t as I saw this. Can someone maybe help me with making a screenshot on a specific part of the screen?

Share this post


Link to post
Share on other sites

ok i tried it on my other 2 PCs too and it doenst work, i tried it on Pcs of friends and family members and theyre gettin' another error, i though w00t as I saw this. Can someone maybe help me with making a screenshot on a specific part of the screen?

??? What's the other error? What's your Windows version? What's your AU3 version?

It still works on my system. It writes the screenshot as it should...


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0