Sign in to follow this  
Followers 0
brodie28

IE.au3 help needed

4 posts in this topic

Is it possible AT ALL, to download an image without opening a new connection to the server? Images that change are not able to be captured with the current features.

Is it possible to use tabs in IE now? I have the latest beta of Autoit, but there doesnt seem to be any new functions to operate tabs.

Thanks alot.

Share this post


Link to post
Share on other sites



Is it possible AT ALL, to download an image without opening a new connection to the server? Images that change are not able to be captured with the current features.

Is it possible to use tabs in IE now? I have the latest beta of Autoit, but there doesnt seem to be any new functions to operate tabs.

Thanks alot.

Please note that as of this writing, the latest beta of AutoIt is older than the production version 3.2.2.0 - please use production.

Regarding image download -- by (security) design in the browser this is not scriptable without human intervention. You can give focus to the image (_IEAction(xxx, "focus")) then use AutoIt to send mouse-clicks (right-click, save as etc) and keystrokes to save the file. It will also be in your browser cache, but there are no utilities for finding it there for the same security reasons.

Regarding tabs - Microsoft has yet to provide much documentation on the use of tabs in IE7. There is an undocumented function in IE.au3 released with 3.2.2.0 called __IENavigate (note double _) that includes some tab creation support -- see the discussion of this here: IE.au3 V2.1-0 (was IE.au3 T2.0-6 pre-release)

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Edit : Dale wrote faster and better :)

Edited by Shevilie

Start here if you are new Valuater's AutoIT 1-2-3Looking for an UDF - Look hereDo you need to do it twice - Autoit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0