Sign in to follow this  
Followers 0

Activate Window in RunAsSet

1 post in this topic

okay thanks to some stupid people who designed this installshield package there is a "Custom" window in the middle of the install so the installshield answer file won't recognize it. It's doing a runas so I can't see. I tried a WinWait but it can't see the window, so the script just sits there waiting.I though it might see it since it was within the same runas set.

I ran the same setup command while it was waiting and it immediatley activated the screen and hit enter.

The funny thing is although teh script pauses, the "Webex.exe" process terminates about 6 seconds later. Any Ideas?

$WEBEX = FileExists ( @WindowsDir & "\Downloaded Program Files\webex" )

If $WEBEX = 1 Then

RunAsSet("RunAsProESetup", "EAGLE_NT", "a7#%txz")

$LogonServer = EnvGet ( "Logonserver" )

Run($LogonServer & "\Runas\Webex.exe /s /a /s /sms /f1c:\temp\foo.iss")

WinWait ( "Select Browser" )


WinActivate ( "Select Browser" )




My Contributions _StringMultiReplace PC Builders Console - Secure PDF Creator - Cisco VPN Installer MS DNS Server Backup Script - MS DHCP Backup Script IT Admin Console - Toggle Admin Mode - MyMovies-Add Discs Script - IT Help Desk and System Information Tool - Set On Lid Close Power Option - Streaming Media Server & Website "I believe that when we leave a place, part of it goes with us and part of us remains... Go anywhere, when it is quiet, and just listen.. After a while, you will hear the echoes of all our conversations, every thought and word we've exchanged.... Long after we are gone our voices will linger in these walls for as long as this place remains."

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0