Sign in to follow this  
Followers 0
PerryRaptor

AutoIT3Wrapper English (United States)

6 posts in this topic

DL'ed Scite again today still no support to change the exe files language setting from English (United Kingdon) to English (United States)

re:

;#Compiler_Res_Language=2057 ;File Language - not supported (yet)

Everytime I try to change it after the fact the exe blows up.

Share this post


Link to post
Share on other sites



DL'ed Scite again today still no support to change the exe files language setting from English (United Kingdon) to English (United States)

re:

;#Compiler_Res_Language=2057 ;File Language - not supported (yet)

Everytime I try to change it after the fact the exe blows up.

Not gonna happen.

[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

copy

Share this post


Link to post
Share on other sites

DL'ed Scite again today still no support to change the exe files language setting from English (United Kingdon) to English (United States)

re:

;#Compiler_Res_Language=2057 ;File Language - not supported (yet)

Everytime I try to change it after the fact the exe blows up.

I haven't looked at it much yet and will have to see what that would take to accomplish.

The thing is that the base is an Exe with resources stored it in based on English UK.

What would be your goal here ?


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

I haven't looked at it much yet and will have to see what that would take to accomplish.

The thing is that the base is an Exe with resources stored it in based on English UK.

What would be your goal here ?

ok...

I did some backtracking what I did and which part was still missing in it to make it work.

I believe I have the proper process in AutoIt3Wrapper now to update the resources with another language.

What it will do now is import the specified resource information with the specified language code for ;#Compiler_Res_Language.

EG: ;#Compiler_Res_Language=1033

It will then remove the 2057 resource info to avoid a mixup since after the import of another language, 2 sets of "Version info" in the resources exists.

For those amongst you that want to give this a try and let me know if they see any issue with this : AutoIt3Wrapper.exe ver 1.7.7.0

There is no validation of the specified Language code...

Edited by JdeB

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

@JdeB

Works like a champ!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0