Sign in to follow this  
Followers 0
Swimming_Bird

Issue with operators working properly

5 posts in this topic

With this code i cant get, <,>,<=, or >= to work properly with this below:

$Local = RegRead ( $reg , 'li-version' )
$newversion = IniRead ( $tempini , 'info' , 'version' , 0 )
MsgBox ( 0 , $Local <= $newversion , $Local & '<=' & $newversion )

the operator returns 1 if they're equal and 0 otherwise, with <,> it always returns 0.

Any idea why these variables may not be formatted properly or somehting?

Share this post


Link to post
Share on other sites



Your dealing with strings so turn them into Integers or Numbers first and then try comparing.

$Local = Int( RegRead ( $reg , 'li-version' ) )
$newversion = Int( IniRead ( $tempini , 'info' , 'version' , 0 ) )
MsgBox ( 0 , $Local <= $newversion , $Local & '<=' & $newversion )

:whistle:

Share this post


Link to post
Share on other sites

Int() or Number(). I used Int previously.

Share this post


Link to post
Share on other sites

ah thanks, i wasnt able to find that int function :whistle:

Share this post


Link to post
Share on other sites

Int() or Number(). I used Int previously.

heh, yea sorry, i deleted the post once i realized you posted edited code :whistle:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0