Jump to content
Sign in to follow this  
Freedom1

Need AutoIt to Interface with Crystal Reports v10�..

Recommended Posts

Freedom1

Im newly introduced to AutoIt and I have found it extremely flexible for my needs. I used to use WinBatch. Now I want to stretch it by being able to run Crystal Reports v10 (Changing parameters, database locations, etc.) from AutoIt.

I searched the forums and found an old (2005) beta of some code to process a Crystal Report. That was developed for a version prior to v10. I was unable to get it to work.

Does anyone have an update for that script or can someone provide a method to run Crystal Reports from AutoIt? Can it be done? Examples welcome!!!

Freedom1

Share this post


Link to post
Share on other sites
ptrex

Share this post


Link to post
Share on other sites
Freedom1

Ptrex,

It was my fault for not using the fix for CR10 correctly. I misread the way it was supposed to be changed.

$CRViewer1 = ObjCreate("Crviewer.Crviewer") <----Orig

$CRViewer1 = ObjCreate("Crviewer.xxxxxxx") <----To be changed.

$CRViewer1 = ObjCreate("Crviewer.CrystalReports10.ActiveXReportViewer.1") <----What I changed it to...didn't work

Should be:

$CRViewer1 = ObjCreate("CrystalReports10.ActiveXReportViewer.1") <----Works fine.

Now I just have to find out how to pass parameters and database locations to it. If you have any knowledge or examples, I'd appreciate them.

Thanks,

Freedom1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.