Jump to content
Sign in to follow this  
GMK

Inconsistent Results

Recommended Posts

GMK

The attached script was my "just-for-fun" script to make my own TV listings (grabbed from IMDB, imported into Excel) of my favorite shows and I'm pretty satisfied with the results, except for the fact that _IETableGetCollection doesn't always seem to work as I think it should. I've attached the script for anyone who would like to use it and/or may find why the results are so inconsistent. (It should be noted that I renamed "ExcelCOM_UDF.au3" to just "Excel.au3" on my computer.)

EDIT: Script removed.

Edited by GMK

Share this post


Link to post
Share on other sites
DaleHohm

Sorry, too much code, no comments and no description of what you expect to happen and what happens instead.

The most common cause of trouble with _IETable* functions is being surprised by table nesting and getting the right index.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
GMK

I'm sorry. The script was quickly put together without any documentation and I wasn't very specific about the problems encountered.

The problem seems to be inconsistent source code with the IMDB pages. Sometimes there are ads loaded in a table before the desired table, while other times the desired table seems to be the only one, or first one. I guess I'll have to figure out a way to look for a table that contains "Next US TV Airings:". I'll gladly take any suggestions.

Share this post


Link to post
Share on other sites
DaleHohm

It looks like the table you want is the first one inside a <div id="tn15content">

So you can get your table like this:

$oDiv = _IEGetObjByID($oIE, "tn15content")

$oTable = _IETagNameGetCollection($oDiv, "table", 0)

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
GMK

Hmmm...I don't have that function. Time to update. And thanks!

Share this post


Link to post
Share on other sites
DaleHohm

Hmmm...I don't have that function. Time to update. And thanks!

You could interchange _IEGetObjByName prior to 3.2.4.0, but I'm happy to get you to upgrade and use the new function :)

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×