Jump to content
Sign in to follow this  
alback

Include error

Recommended Posts

alback

I receive this error when I attempt to start the AutoIT debugger. I presume it results from some mixup with the include files but I have performed a complete re-install and still get the error.

A3LListView.au3

Func _ListView_AddArray(...)

Error: duplicate function name

Thanks

Share this post


Link to post
Share on other sites
PsaltyDS

I receive this error when I attempt to start the AutoIT debugger. I presume it results from some mixup with the include files but I have performed a complete re-install and still get the error.

A3LListView.au3

Func _ListView_AddArray(...)

Error: duplicate function name

Thanks

Have you downloaded the latest version of PaulIA's Auto3Lib.au3 UDFs? The A3LListView.au3 include file is part of that collection, and the version I have contains:

_ListView_AddArray

--------------------------------------------------------------------------------

Adds items from an array to the control

_ListView_AddArray($hWnd, ByRef $aItems)

So if you are using that UDF and also declaring a function of your own by that name... you got an issue. If PaulIA's UDF is causing that on its own, you should post it to the topic I linked above. PaulIA is very responsive to feedback there.

:)

Edited by PsaltyDS

Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites
PaulIA

Have you downloaded the latest version of PaulIA's Auto3Lib.au3 UDFs? The A3LListView.au3 include file is part of that collection, and the version I have contains:

So if you are using that UDF and also declaring a function of your own by that name... you got an issue. If PaulIA's UDF is causing that on its own, you should post it to the topic I linked above. PaulIA is very responsive to feedback there.

:)

Answered in other thread.

Auto3Lib: A library of over 1200 functions for AutoIt

Share this post


Link to post
Share on other sites
alback

Have you downloaded the latest version of PaulIA's Auto3Lib.au3 UDFs? The A3LListView.au3 include file is part of that collection, and the version I have contains:

So if you are using that UDF and also declaring a function of your own by that name... you got an issue. If PaulIA's UDF is causing that on its own, you should post it to the topic I linked above. PaulIA is very responsive to feedback there.

:)

For future reference, Paul's Auto3Lib installer targets the standard include directory. Stumpii based his debugger on the beta version which when installed, has an include directory of its own. I have asked Stumpii if we can change his debugger to use the standard version and therefore the Auto3Lib updated include files.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×