Jump to content

How to send chinese font with send?


Recommended Posts

In some software installation, I will input some chinese charactor, I use send command send some chinese charactors, But it didn't work. How to dissolve this problem? Is there any way?

Link to post
Share on other sites

In some software installation, I will input some chinese charactor, I use send command send some chinese charactors, But it didn't work. How to dissolve this problem? Is there any way?

<{POST_SNAPBACK}>

AutoIt is not able to send Unicode characters so there's no way to do this.
Link to post
Share on other sites

In some software installation, I will input some chinese charactor, I use send command send some chinese charactors, But it didn't work. How to dissolve this problem? Is there any way?

<{POST_SNAPBACK}>

if u want to do it, don't use sent, just use ControlSetText
Link to post
Share on other sites

If you take ezzetabi's suggestion, then I suggest dumping the contents of the clipboard to a variable BEFORE you set the text to the clipboard. Then after your script is done and AFTER you dump the contents of the clipboard, put the previous contents back on there. That way if the user stores information on the clipboard that they use often (like I do) then you aren't causing anymore headaches than absolutly necisary. It probably won't work with images (at least not yet) but it will work in 99% of the cirumstances.

*** Matt @ MPCS

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...