Jump to content
Sign in to follow this  
ChVL

Problems with compilation.

Recommended Posts

ChVL

Any compiled exe-file has the size approximately 200 КБ and independently is not started, demands presence of an initial exe-file.

AutoIt v3.2.4.9.

Where to search for the reason?

Share this post


Link to post
Share on other sites
ChVL

1. Win XP Pro SP2

2. There are no error messages.

Installation of the program is made correctly but only when there are both of a exe-file: compiled and initial.

Share this post


Link to post
Share on other sites
Jos

1. Win XP Pro SP2

2. There are no error messages.

Installation of the program is made correctly but only when there are both of a exe-file: compiled and initial.

Could be me but I don't really understand what your problem is ...... maybe you can explain a bit more ? :) Edited by JdeB

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
ChVL

OK. There is a au3-script and an initial file. I do compilation. For any program the compiled exe-file has the size approximately 200 КB, also does not depend on the size of an initial exe-file. Such compiled exe-file does not work independently, and demands presence of an initial exe-file

Share this post


Link to post
Share on other sites
Jos

OK. There is a au3-script and an initial file. I do compilation. For any program the compiled exe-file has the size approximately 200 ÐB, also does not depend on the size of an initial exe-file. Such compiled exe-file does not work independently, and demands presence of an initial exe-file

The size are all compiled scripts are more or less the same ...that is correct, but they are self-contained and will run independent of any other EXE ... :) Edited by JdeB

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
ChVL

Excuse me, I should read through closely still time the Help. I have found function FileInstall () which is necessary for addition of a file and reception of one compiled SFX-file.

Now I have other problem. How it is possible to make silent installation of the program? Function (Run ($ProgramPath, " ", @SW_HIDE)) does not hide appearing windows during automatic installation. Function WinSetState it is impossible to share with WinWaitActive. Whether has the decision this problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×