Sign in to follow this  
Followers 0
vatobeto

Problems with Autoit closing at end

3 posts in this topic

#1 ·  Posted (edited)

Since I always seem to lose the serial numbers with my purchased programs, I am now making automatic installers for them. When making one for Dreamweaver, I couldn't get either the AutoIt Script or the Dreamweaver program to close automatically - i.e. using various techniques: taskkill (DOS), or the processFunctions UDF. Also, there is a button in the Dreamweaver startup screen, that I can't access, it seems to be part of a surrounding object. Screencap below, with current version of installer. Thanks, if anyone can offer suggestions, other than RTFM, which I have.

vatobeto.

post-22123-1181893706_thumb.jpg

Edited by vatobeto

Share this post


Link to post
Share on other sites



Macromedia stuff like ColdFusion don't (as far as I have been able to find) expose any API for scripted control. They are not Windows 'windows', they are graphical objects created by Macromedia software, not Windows APIs. I've beat my head against that wall for a little while too... the best I have achieved is blind Send("{TAB}") operations and the like.

No fun.

:rolleyes:


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Perhaps silent installation maybe better as mentioned in this PDF. It make the installation easier and more reliable.

:rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0