Sign in to follow this  
Followers 0
rickd

Including UDF in complied exe?

6 posts in this topic

Hi,

I have a script that uses an included udf (#include <_XMLDomWrapper.au3>). The script works fine on my PC, but when I compile it to an exe and then put it on another PC on our network the script no longer works (won't open XML file).

The only difference is that my development PC has the XMLDomWrapper.au3 file and the PC I deploy the exe to doesn't (all other files/paths are exactly the same). So I assume the error is due to this file not being present, can it be complied into the exe? Or is some other reason possibly causing my problem?

Thanks for any help/suggestions.

Share this post


Link to post
Share on other sites



Hi,

I have a script that uses an included udf (#include <_XMLDomWrapper.au3>). The script works fine on my PC, but when I compile it to an exe and then put it on another PC on our network the script no longer works (won't open XML file).

The only difference is that my development PC has the XMLDomWrapper.au3 file and the PC I deploy the exe to doesn't (all other files/paths are exactly the same). So I assume the error is due to this file not being present, can it be complied into the exe? Or is some other reason possibly causing my problem?

Thanks for any help/suggestions.

The problem is with your PC not the script, if you want you can copy the whole thing into your script and see if it works.

Share this post


Link to post
Share on other sites

Differcult to help without seeing the script. A script will not compile without _XMLDomWrapper.au3 when you have used "#include <_XMLDomWrapper.au3>" in your script. The problem most likely is elsewhere.

Share this post


Link to post
Share on other sites

If you compile the script and allow decompile, then decompile the script (use a new name or target) and see if all of the _XMLDomWrapper.au3 functions are in your newly decompiled script.

I thought and I might be wrong but if you used #Include < > then the include file is ment to be in your autoit include directory, if it is just sitting in the same folder as your script you should use speach marks " " and not < >

#include "_XMLDomWrapper.au3"

Share this post


Link to post
Share on other sites

If you compile the script and allow decompile, then decompile the script (use a new name or target) and see if all of the _XMLDomWrapper.au3 functions are in your newly decompiled script.

I thought and I might be wrong but if you used #Include < > then the include file is ment to be in your autoit include directory, if it is just sitting in the same folder as your script you should use speach marks " " and not < >

#include "_XMLDomWrapper.au3"

:whistle:

Using #include <>

Standard library

User-defined libraries

Script directory

Using #include "" (This is the reverse of #include <>).

Script directory

User-defined libraries

Standard library

A note about using the /AutoIt3ExecuteScript option. Since the standard library is searched for in the current interpreter's directory, the standard library functions will not be found; that library will only be found when run through AutoIt3.exe. It's recommended that you compile a script to the .a3x format before attempting to run it with /AutoIt3ExecuteScript.

Aut2Exe uses the same algorithm as AutoIt3.exe with the only difference being it looks for the Include sub-directory as being in a sibling directory to itself (..\Include).

If Opt("TrayIconDebug",1) only 64 include files name can be displayed in the traytooltip. for the other no filename will be displayed.

It is same if you use "" or <>. It will always produce the same, except if is File.au3 in AutoIt include dir and you have File.au3 in script dir then you use #include "file.au3". Else you include with <>

I can do signature me.

Share this post


Link to post
Share on other sites

Thanks for responses, I now see the problem is not including the udf.

I found out the PC I am trying to run my exe on is running IIS. I think this may cause problem with the path to the XML file. On my PC the xml is in the same dir as script, so I just have "guide.xml" as the path, but maybe the PC running IIS requires absolute path, I tired that and still it will not open the file.

I am stuck for now...

@error codes I am getting from XMLFileOpen are "-2147024893" and "-2146697210"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0