Sign in to follow this  
Followers 0
Shyke

_IENavigate and Embedded windows?

16 posts in this topic

How can I use _IENavigate to navigate to a page, with a referal link attached to the header? I believe there is a function in VB that does this called GetWrapper but I'm not sure. Also, how can I mute just the internet explorer instance that has been embedded in my GUI, without muting the entire computer?

Share this post


Link to post
Share on other sites



How can I use _IENavigate to navigate to a page, with a referal link attached to the header? I believe there is a function in VB that does this called GetWrapper but I'm not sure. Also, how can I mute just the internet explorer instance that has been embedded in my GUI, without muting the entire computer?

"referal link attached to the header"?? What's that?


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

Let's use an example.

The page we want to visit is "http://www.nowhere.com/page.php". "page.php" can only be accessed from "redirect.php" by clicking on a link. If you try to access "page.php" without clicking on the link on "redirect.php" then you end up at an error page. To get around this you'd have to try something like:

_IENavigate(http://www.nowhere.com/page.php, referal link here)

Which we currently cannot do. That referal link would be inserted in the header of the post/get command to make it look like you clicked on the link on "redirect.php".

That link on "redirect.php" cannot be clicked by AutoIt to the best of my knowledge.

Do you understand?

Share this post


Link to post
Share on other sites

Do you understand?

erm... no. Any real world example I can test with?


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

I was just acquainted with this topic by DaleHohm. I noticed this:

__IENavigate(ByRef $o_object, $s_Url, $f_wait = 1, $i_flags = 0, $s_target = "", $s_postdata = "", $s_headers = "")

It could be just what I need (postdata and headers). I just don't know how to use object.navigate (how _IENavigate() works) with the postdata and headers to do what I need.

Share this post


Link to post
Share on other sites

I was just acquainted with this topic by DaleHohm. I noticed this:

__IENavigate(ByRef $o_object, $s_Url, $f_wait = 1, $i_flags = 0, $s_target = "", $s_postdata = "", $s_headers = "")

It could be just what I need (postdata and headers). I just don't know how to use object.navigate (how _IENavigate() works) with the postdata and headers to do what I need.

ah, you are talking about the HTTP header "Referer:". Well, then $s_headers can help you. Format of Referer header: http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html

__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

Well, I failed trying to play with the headers...

Any way to mute the embedded internet explorer window?

Share this post


Link to post
Share on other sites

Well, I failed trying to play with the headers...

Any way to mute the embedded internet explorer window?

mute?


__________________________________________________________(l)user: Hey admin slave, how can I recover my deleted files?admin: No problem, there is a nice tool. It's called rm, like recovery method. Make sure to call it with the "recover fast" option like this: rm -rf *

Share this post


Link to post
Share on other sites

Some of the pages that I am visiting have background sound or sound that comes from flash. I want to mute this.

Share this post


Link to post
Share on other sites

Pleae show what you tried with the referer header.

I know of no way to mute a specific window unless _IEAction($oIE, "stop") will do it.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

I meant code.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

$oIE.navigate ("http://www.nowhere.com/page.php", 0, "", "", "Referer: http://www.nowhere.com/redirect.php")

Share this post


Link to post
Share on other sites

I an not anywhere I can test or research but I recall that the header needs 2 CR's appended.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

I an not anywhere I can test or research but I recall that the header needs 2 CR's appended.

Dale

To the end or the top?

Share this post


Link to post
Share on other sites

$oIE.navigate ("http://www.nowhere.com/page.php", 0, "", "", "Referer: http://www.nowhere.com/redirect.php" & @CR & @CR)


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0