Sign in to follow this  
Followers 0
probedrone

Remote Scripting Does Not Work on Windows Server 2003

5 posts in this topic

Hi,

I made a test script that I want to use on remote machines, using psexec to distribute it. It works flawlessly on the WinXP machines that I tried it on, but for some reason the autoit part of the script will not load properly on Windows Server 2003...

I know its not a issue with psexec, because I used the -i switch and I generated a batch file to copy some files over, execute the autoit script, then do some cleanup, and the batch file was able to execute without problems...

Its just that autoit would not load up the program its suppose to test on win2003

Share this post


Link to post
Share on other sites



Come back with a clearer problem description and sample code showing your code snippets. A search on the psexec forum, as well as searching here, will show you that there are many issues w/ psexec, particularly wrt console output. You may also have hung the psexec service, which you may need to clean out (registry stuff) before attempting again.

I found an alternative tool which suffers from none of the above problems, I posted these results a few months ago, and should be readily locatable.


Reading the help file before you post... Not only will it make you look smarter, it will make you smarter.

Share this post


Link to post
Share on other sites

I tried the most basic approach and it still will not work.

I created the autoit script that just prints out a msgbox

Open a cmd window and typed: psexec.exe \\server -u username -p password -c -f -i test.exe

On windowsXP: no problem. Msgbox is shown on remote machine

On windowsServer2003: the cmd window hangs and nothing happens on the remote machine...

Share this post


Link to post
Share on other sites

Has anybody run into the problem before? it seems to me like on win2003 it only allows psexec to run programs in the console session and not interactively. The autoit script runs fine by itself when I remote desktop to the server.

Share this post


Link to post
Share on other sites

Has anybody run into the problem before? it seems to me like on win2003 it only allows psexec to run programs in the console session and not interactively. The autoit script runs fine by itself when I remote desktop to the server.

I quit using PSExec a long time ago. Use SCHTASKS.exe instead. Copy your script across over the network, then schedule a one-time task to run it.

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0