Sign in to follow this  
Followers 0
SlimShady

Crimson Editor

11 posts in this topic

#1 ·  Posted (edited)

I know everyone is in love with SCiTE.

I'm not, because I can't change the font to what I want.

So I switched to Crimson Editor.

Just like SCiTE, you can attach tools to hotkeys.

Eg: Compile, run script, syntax check with au3check, etc.

It also has syntax highlighting.

Problem is, that the autoit3.key isn't up-to-date.

Functions like InetGet aren't highlighted.

@JdeB:

I saw your name in the autoit3.key file.

How did you create the file?

You didn't create it by hand, or did you?

I think I can generate the file myself, if I knew where the info is that has to be extracted.

Keywords, macros, functions.

Edit:

Never mind. After studying the file, I see that it ain't that hard.

Edit2:

Better yet. If you check the docs-v3.0.103-src.zip, you'll find the up-to-date file.

Edited by SlimShady

Share this post


Link to post
Share on other sites



Allright. That's good.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

I know everyone is in love with SCiTE.

I'm not, because I can't change the font to what I want.

<{POST_SNAPBACK}>

What is the problem with changing the font in SciTe Edited by JdeB

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Perhaps too easy in Scite?

Control and mouse to increase or decrease font size.

Ctrl+F11 to toggle override font.

:)

Share this post


Link to post
Share on other sites

I want to change the default font to Courier New, size 10pt.

And I want it to keep that font.

Share this post


Link to post
Share on other sites

I want to change the default font to Courier New, size 10pt.

And I want it to keep that font.

<{POST_SNAPBACK}>

Scite Font and syntax highlighting Colors

Add these to the "User Option File" when you want to customize Font or color settings:

### The default configuration sets Scite to use monospace font.

### and the default font type/size:Courier New,size:10

# Start in Proportional font:

font.override=

# To change the default font add this:

font.monospace=font:Courier New,size:12

### these are all the definitions for all different types of code color settings

### you can customize them all if you want.

# White space

style.au3.0=fore:#000000,$(font.au3)

# Comment line

style.au3.1=fore:#009933,italics

# Comment block

style.au3.2=fore:#669900,italics

# Number

style.au3.3=fore:#AC00A9,bold,italics

# Function

style.au3.4=fore:#000090,bold,italics

# Keyword

style.au3.5=fore:#0000FF,bold

# Macro

style.au3.6=fore:#FF33FF,bold

# String

style.au3.7=fore:#9999CC,bold

# Operator

style.au3.8=fore:#FF0000,bold

# Variable

style.au3.9=fore:#AA0000,bold

# Sent keys in string

style.au3.10=fore:#FF8800,bold

# Pre-Processor

style.au3.11=fore:#F000FF,italics

# Special

style.au3.12=fore:#A00FF0,italics


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Allright. When I get home, I'll try some more.

Share this post


Link to post
Share on other sites

Nope I can't make it work.

I get Arial as the default font.

In the SCiTE Global properties file, I have this:

if PLAT_WIN
    font.base=font:Verdana,size:10,$(font.override)
    font.small=font:Verdana,size:9,$(font.override)
    font.comment=font:Tahoma,size:10,$(font.override)
    font.code.comment.box=$(font.comment),$(font.override)
    font.code.comment.line=$(font.comment),$(font.override)
    font.code.comment.doc=$(font.comment),$(font.override)
    font.text=font:Verdana,size:10,$(font.override)
    font.text.comment=font:Verdana,size:10,$(font.override)
    font.embedded.base=font:Verdana,size:10,$(font.override)
    font.embedded.comment=font:Comic Sans MS,size:10,$(font.override)
    font.vbs=font:Lucida Sans Unicode,size:10,$(font.override)
    
   # To change the default font add this: 
   font.monospace=font:Courier New,size:10
   font.override=

And in the user options file:

# To change the default font add this: 
font.monospace=font:Courier New,size:10
font.override=

So I'm staying with Crimson...

Share this post


Link to post
Share on other sites

font.monospace=font:Lucida Console,size:9

is the line in my user properties file. Are you sure you don't have the alternate monospace font turned on [CTRL+F11]?


Who else would I be?

Share this post


Link to post
Share on other sites

font.monospace=font:Lucida Console,size:9

is the line in my user properties file. Are you sure you don't have the alternate monospace font turned on [CTRL+F11]?

<{POST_SNAPBACK}>

The original SciteGlobal.properties file looks like:

font.monospace=font:Courier New,size:10
font.override=$(font.monospace)
This is to make it start with Courier New 10.

When you change to : "font.override=" then it will start with the defined proportional font defined with:

font.base=font:Verdana,size:10,$(font.override)

I know is somewhat confusing but theres not much i can do about that.


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0